Help - Search - Members - Calendar
Full Version: Help Requested - 6000Cd Radio Permanently In 'one Hour Mode'
Ford Owners Club - Ford Forums > General Forums > Audio & Electronics
timbo50
Any help would be greatly appreciated. The original 6000CD fitted into my 2007 Mondeo suddenly decided to go permanently into one hour mode. Local Ford franchise thought the radio was defective, sent it away and came back with no fault detected. Then took it to an ICE specialist who checked the radio and no fault found. Re-installed and OK for a short while then reverted to one hour mode. I bought a new radio and fitted it, OK to start with then went into one hour mode. All fuses checked and OK.

I've had suggestions that it may be (1) the switched live feed or (2) the ECU.

Before spending more money on fruitless diagnostics, I wonder if anyone has experienced this or knows what the problem is likely to be?

Any help whatsoever would be appreciated.
tomtom70
If your "Mondeo 2007" is already the Mk4 (new in 2007), there is no switched live feed, and the "ECU"(s!) to be checked are the instrument cluster and the (smart) junction box. I think there is an TSI on this (which your dealer should be able to find).
timbo50
Hi Thomas, thanks for the reply but my Mondeo is the last of the older model. What is a TSI? Would your suggestion apply to my model?


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.