Help - Search - Members - Calendar
Full Version: High Oil Pressure / Oil Pressure Relief Valve
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
getaway
Hi all - I've just fitted a brand new crated engine (1.8 Black top Zetec R) and the oil pressure is 90PSI at tickover. General consensus seems to be that it's a problem the oil pressure relief valve - anyone know how to get to this as the pictures in my Haynes manual are for a Zetec-E and it doesn't look the same at all?

Cheers
gaz6076
You should have some sort of warranty with a brand new engine, even reconditioned ones.
getaway
[quote name='gaz6076' post='13797' date='Mar 1 2009, 06:42 PM']You should have some sort of warranty with a brand new engine, even reconditioned ones.[/quote]

Hmmm.. doubt it - it was from a main dealer but bought off eBay and they're miles away, don't think they'll be sending someone round to fix it insitu.

It should be a relatively easy fix if I had an idea where to locate it
gaz6076
Kl. I would be phoning and asking them where it is then.

If a get a chance to look round one I'll let you know where it is.
getaway
[quote name='gaz6076' post='13904' date='Mar 2 2009, 06:31 PM']Kl. I would be phoning and asking them where it is then.

If a get a chance to look round one I'll let you know where it is.[/quote]

Thanks - it never crossed my mind to call the dealer (must be their usual levels of helpfullness!), but I'll give them a go.
Simon S
[quote name='getaway' post='13953' date='Mar 2 2009, 10:46 PM']Thanks - it never crossed my mind to call the dealer (must be their usual levels of helpfullness!), but I'll give them a go.[/quote]
I had an Audi engine that did this. Trouble was when the valve opened it stuck open resulting in next to no oil pressure at idle.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615