Help - Search - Members - Calendar
Full Version: Using Coolant
Ford Owners Club - Ford Forums > Ford Models > Ford KA / StreetKA Club
Kevee
Hello,

I was checking my KA the other day and noticed the coolant was down to the min mark, I had topped it up to the max mark a couple of weeks before.

The car is used every day (Mon - Fri) so if there was a problem I would expect to see the level go down quicker. I topped it up and run the engine and did not see any loss under the car and it seemed to stay at the max level.

Anyone have any ideas as to what could be happening?

Many Thanks,

Kevin
Stoney871
Check the expansion tank, lid and pipes.
If it's loose or leaking then you can lose coolant by evaporation.
Kevee
Thanks for the info, if it is a small leak or crack would a compression test highlight that?
delboy
had same happen on my ford galaxy. it turned out to be the expansin bottle seal on the cap had its days so had to
replace the screw top as they dont sell the seals on their own. thats the first thing i would replace as it's the easiest to do
then go from there. look for white fluffy deposits on pipes etc as that will indicate a leak but do change the filler cap first m8


Full Colour Version: Using Coolant
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615