Help - Search - Members - Calendar
Full Version: Turbo Issue
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
martyntdci
Earlier on i started the car up at our local argos store, to only find a new noise coming from the bay. It sound more like a humming than a whistle. at first i thought i had a air leak from a boost pipe, so popped the bonnet and listened whilst the g/f revved the car but no luck. It gets louder as you rev the car but is very very noticeable at tick over. im just wondering at this stage if it is my turbo on last legs. car is a 1.8 tdci dutatorq 115 on a 2008 plate.

It kicks out smoke on boost, and has definatly lost umpf... many thanks in advance mart
Mike77
If its noticeable at tickover the turbo won't be turning over then, only kicks in at about 1800rpm. Would sway towards an air leak somewhere, sometimes a lot harder to find than you think. Doesn't necessarily have to be a rubber hose either, one of the metal ones may have split, quite common apparently. Check all connecting pipes first.
martyntdci
thanks, will have a check in the morning and let you know and there is also a slight burning/smoldering smell when the heaters are on?? but thanks very much
martyntdci
had a look at pipes today, especially the bend on the left hand side of the bay, and seem to be ok. so ive compared sounds with those on youtube and mine, and tbh it does sound like the turbo..... As i have to change this, would the 2l, or the 2.2 turbo fit as a upgraded part?? what do these 1.8 duratorq boost actually boost at? i know they are vv turbo's but before this happened on the torq app i was hitting between 1.4 and 1.6 bar of boost, and 145 bhp. i know they allow a certain degree for over boost but only short burst. im currently wondering if this is what has damaged my turbo, or is it wear and tear (just under 68k).

Any info please many thanks mart
Mike77
145bhp ? Has it been remapped ? I can't give any advice on weather the other turbos will fit, I would hazard a guess at NO, but I may be wrong. As far as boost is concerned I think its roughly 1800rpm they kick in at, give or take a 100rpm's or so.
martyntdci
yes its being remapped, boost starts at approx 1500 just like what you said, i reach peak torque at just over 3.5k which is say 1.5 bar, which is approx 22 psi. im wondering if this is correct whith a map? no other mods as yet to got with it, just a standard set up..
Mike77
Same as mine then, just a remap, think the map made the turbo come in slightly earlier. Not sure about what bar and psi it should be running at though.
martyntdci
what kind of map do you have? if you wish you could have a go of my torq app if you fancied a meet up? depending on distance lol
Mike77
Dunno what type it was lol, a mate if mine has a franchise doing remaps, he reckoned about 38bhp and about 50 extra torque. I'm not really bothered about figures, I can feel all the difference lol.
martyntdci
had a minor tear in a pipe, which was power loss, and the whining noise was the alternator on its way out....


Full Colour Version: Turbo Issue
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.