Help - Search - Members - Calendar
Full Version: A Few Issues With My 05 Tdci Mondeo Lx
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Clive79
Hi there im new to this forum. I currently own a TDCI 2,0 litre 05 plate Mondeo.

i have a few niggling issues.

1) I cant find the Aux input on the 6000CD radio, i dont know if anyone can advise.
2) Every now and again the car seems to lose power and a coil light starts flashing on the dashboard
3) Its cold at the moment at the moment so the Snow icon comes on, but it never seems to go off.

Can anyone advise on these issues


Also does anyone know where i can download the Haynes 2003-2007 manual for the MK3 Mondeo.?


Much appreciated.

Kind Regards

Clive
gforce
Hi mate, welcome to the forum.

The AUX input should be visible when you open the glovebox.
Not sure about the power loss issue if it's just intermittent like that. Have you any starting issues that may point to injector or EGR trouble?
The snow icon - I'm not sure what sort of temps you're experiencing wherever you are, but the snowflake should only illuminate below 4 degrees centigrade. Should be amber from 4 - 0, and red anything below zero (freezing).

Not sure about a download location but I'm sure you can pick up Haynes from many stores and online outlets, or maybe get a second hand bargain on ebay.

http://www.ebay.co.uk/itm/Ford-Mondeo-Petrol-Diesel-2003-2007-Haynes-Manual-4619-/181040606822?pt=UK_CarParts_Vehicles_Manuals_Litterature_ET&hash=item2a26dc6e66
Clive79
Thanks for that. I opened the glove box and just cant see it. ive pulled out what feels like a light bulb.

The snowflake gauge is Amber, i guess this is normal then as its been about -2 degrees in london recently.

Now and again i get slight starting issues, but usually goes away after a 2nd attempt.
Clive79
This is what have found in the glove box.

is this supposed to be it? If not can someone send a pic of theres so i can identfy it.

Thanks in advance.
gforce
That's def your bulb holder mate. Stick a 501 bulb in there and that's your glovebox light. I had a Mondeo in the past with an AUX input in the glovebox but can't remember exactly where it is. There is a chance that you don't have an AUX fitted unfortunately!

As said, the snowflake should be amber between zero and four degrees, red below zero, and not lit up at all above four degrees. Cycle through the display options (pressing the button on the indicator stalk) to check the temp when the icon is lit up.
gforce
Found a couple of pics to help you confirm if you have the AUX input...it's at the back of the glove box in the bottom right corner. I forgot as the one in my Focus is at the front. See pics below of what to look for in the Mondeo Mk3. Also notice in pic 1 the location of the bulb (top, centre) in case you've just found you're holder dangling about and aren't sure where it should be mounted.


Clive79
Mate you have my year! ive just gone out to the car and plugged in my phone. Ive been looking all year for it, i assumed i had to pull out the glove box and plug something into the back of the car radio, When i had been staring at it in front of me all this time. Its really silly that its not shown in the audio manual.

Thank you so much!
gforce
Don't worry mate, you're not the first to be caught out with that one!


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.