Help - Search - Members - Calendar
Full Version: 54Plate Tdci Focus
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
andrewl6527
I've got a 54 focus diesel had trouble starting so I changed the glow plugs.solved... Now and then the glow plug light flashes and I lose all power and the car cuts out. Switch off and alls ok for a few days then it happens again.

Been told its a sensor and also the turbo is on its way out.

Anyone had the same problem and resolved this or anyone know what is needed


Many thanks
Steve
in regards to your Turbo.. give Essex Turbos a call on 01376 50 45 93

or go to [url="http://www.essexturbos.com"]http://www.essexturbos.com[/url]

they do great recon turbos
andrewl6527
So you saying its defiantly the turbo
rivnog
I too had this problem with my car, focus tdci 115. It would just cut out at 70mph. It turned out to be my injectors.

It cost a lot of money but it fixed the problem

A nearby diesel delphi speclised fixed my car but since then i have found cheaper delphi garage.

They could check for any faults on their computer,


Full Colour Version: 54Plate Tdci Focus
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615