Help - Search - Members - Calendar
Full Version: No Power To Ford Ka 2007
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
enzorocket
__hello FOC.
As you can gather im new on the forum and desperately need some advice or help.

My daughter owns a 2007 Ford KA, she has had it from new and up to a year ago, drove it every day. She has been away travelling for the last 6 months, on her return she tried to start the car but there was no power, no ignition, no hazard light etc.

I assumed it needed charging, took the battery and successfully charged it - the charger reported charged and maintaining. I put it back in the car, attached everything as it was but there is still no power to the car, not even hazard light or central locking, nothing!

I have since, taken the battery to a mechanic who tested it fine with an 81% test rating. He then attempted to connect everything and still no power. He has also checked the fuses in the main engine compartment which all appear ok.

We are all baffled, he has suggested I take it to FORD directly to see if they can get to the bottom of it but thought id try the owners club first just in case someone has had a similar issue and resolved it.

Would greatly appreciate any help / advice out there.
Steve
At a guess there may be a main ECU fuse that is probably seperate from the car fuses. I dont own a KA so this is only a guess i'm afraid
Stoney871
It may be your gem module has gone.
A good auto electrician may be your best bet.


Full Colour Version: No Power To Ford Ka 2007
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.