Help - Search - Members - Calendar
Full Version: Trip Computer Question - '54 2.0 Tdci Ghia
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Iandb
Folks,

Recently brought this car and am generally really pleased. But unsure if the trip comp is faulty or if it is in fact correct and normal

In my wifes car her trip computer has a whole range of info, more than on my Mondeo. But one of the main things is that the MPG reading is static on the Mondeo. But on the wives car if you go to this it changes constanly depending on your driving giving you a real time reading.

Also when I flick through there is a temp display but it only has 3 dashes so is obviously not working? Is this linked to the "Snowflake" light on the dash panel which has been constantly on red.

Thanks

Ian
Stoney871
I believe what you are referring to is the instant fuel reading.
Also the lack of temperature reading seems to point to a duff sensor or a damaged cable.
The snowflake is connected to this problem too.
BigD
The snowflake should only be red if it's 0C or below. As above, faulty sensor or wiring.

Regarding the MPG reading, it probably hasn't been reset for ages. Put the display onto MPG, and hold down the button (below the screen) for about 5s to reset it. Next time you drive, the MPG will be all over the place (everywhere between 30mpg and 99mpg!), but will level out a bit after a few miles.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.