Help - Search - Members - Calendar
Full Version: Car Engine Still Running Without The Key In The Ignition D:
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
GoldenLeaf
I had to just quickly move my car on my drive earlier today. I then turned off the ignition and took the key out, to find that the engine was still running. I put the key back in the ignition turned it forward and back again, this time the engine turned off. I tried starting the engine again, and now everything is working fine.

Any idea wtf happened? Has anyone else ever experienced this on their Focus?
artscot79
Very unusual ive had it on a vw before and it was the ignition barrell was worn and needing replaced but it lasted at least a year before i had to get it done
Stoney871
The ignition relay switch must have stuck temporarily.
Preee
Also check your Oil level , if its low then it could be running on oil , which could be from a failing oil seals or turbo.

Just check to make sure it's not this , if you think this could be the problem do not run the car as "Engine Run away " could happen.
GoldenLeaf
I hope it's not oil related :S I did check the level a couple of weeks ago, but I'll check again tomorrow (fingers crossed!).
For now I wish to believe that it was caused by what Clive said :P
That Diesel engine runaway sounds a bit scary, I just read up on it.

Thanks for the info guys!
Stoney871
I saw a runaway on a transit connect once.
WheeeeeeEEEEE BANG!
GoldenLeaf
D: D: D: D: Don't scare me!

And a happy new year also :D


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.