Help - Search - Members - Calendar
Full Version: Battery Being Drained Flat On 59 Plate Mondeo Edge Estate.
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Piston Broke
Had this car for about 8 months with no problems, but it has been run everyday, and in warmer weather !!.
Parked it up friday afternoon and didn't try to start it til today (mon 21.1.2013.)

Battery had gone flat.

AA Home Start checked the battery and charging system, perfect. Bu,t he detected that there was an intermittant drain of between 0.3A which would jump upto 1.1Amp, that with the ignition off and the car dead locked by the key fob.

I have noticed elsewhere on the internet that people have been commenting on this problem, one who had spent a fortune on Auto Electrical Engineers but still didn't resolve the problem.

I wonder if any of our members experienced this ??
BigD
It will always use some power, i.e. the clock, any alarm/immobiliser, central locking etc.

Possibly a bad earth somewhere, or maybe the power save relay?
jeebowhite
whats the mileage and service history of the car?
Piston Broke
[quote name='BigD' timestamp='1358807277' post='229128']
It will always use some power, i.e. the clock, any alarm/immobiliser, central locking etc.

Possibly a bad earth somewhere, or maybe the power save relay?
[/quote]
Thanks for that Big D, err, where is the power save relay and how could I tell if thats the problem please ?
Piston Broke
[quote name='jeebowhite' timestamp='1358862560' post='229219']
whats the mileage and service history of the car?
[/quote]

Hi, mileage is 91400 and full service history, last serviced at Ford garage at 87k.

Thanks
bladeage
Check that your engine earth to chassis is tight, I had this problem on my motorhome and for some reason because it was loose the battery power was going straight to earth and draining over night,tightened it up and never done it since?!
Piston Broke
[quote name='bladeage' timestamp='1358875345' post='229278']
Check that your engine earth to chassis is tight, I had this problem on my motorhome and for some reason because it was loose the battery power was going straight to earth and draining over night,tightened it up and never done it since?!
[/quote]

Thanks for the tip, will do
Piston Broke
Noticed when using the car today that my mobile phone is not connecting to the cars bluetooth. Usually connects as soon as radio is turned on. Wonder if that could be the problem? Not had chance to see in the radio menu and memory if it still remembers the phone, but the phone says that it is still paired with Ford Audio.
Just another thought, if the radio is left turned on when the ignition is switched off and the car locked, (I know the radio is quieted and no lights on the dash anywhere), can it still connect to my phone ? reason being that the radio will only be about a metre from the phone nearly all of the time, allbeit that it is next to me on the settee in my lounge, the car being just outside the lounge wall on the drive ! :rolleyes:
jeebowhite
bluetooth should connect when the radio is on, but these days, the car has a one hour radio mode, so 61 minutes later, radio should go off anyway!
adamhawk
It sounds very much like a loose earth, had the same issue on a Fiesta! However like with anything these days something so small as an interior light can drain the whole battery in hours! Be sure that all is switched off, I know on the fiesta that even if I did not manually and physically turn the radio off via the on/off button, then it would hibernate but drain throughout its off time.
Piston Broke
Thanks Guys, I will check this weekend for any obvious loose earths. I've seen a current leakage detector on ebay. The connector end is in the shape of a blade fuse. Check each fuse position one at a time to see if I could find it. For £15 it maybe a good investment ?
jeebowhite
sounds good, so you replace the proper fuse, with this fuse shaped leak detector, and if there is a current, it picks it up?

sounds a good idea!
Piston Broke
Hi, well that could be it in theory. Suppose it means being sat in the car doors locked trying one fuse at a time, shouldn't take more than a couple of days ! especially if there's another fuse box under the bonnet (one in the boot as well ?) I've tried to attach a photo of the tester but not sure if I've done it right.
jeebowhite
Looks like an alright investment to be fair!
jeebowhite

Did you manage to find the source of the issue with the detector?

 

Do you find it a good investment?

 

Also do you mind providing a link to this? I am half tempted myself?

wase16ll
a cheap volt/amp meter will do the same, and be usefull elsewhere for other jobs..
connect amp meter up, close all doors, turn off all electrics...give it a minute to allow anything like interior light delays to switch off...then take the reading, if high [ideally looking for around 0.05 or lower, so 0.3- 1.1 is way too high] then pull the fuses till it drops..[for interior fuses then either run amp meter through open window or pull the bulb from interior lights once you know its not the lights causing the problem]
most common causes are things like glove box/boot lights staying on, cig lighters shorting out, alarms shorting.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615