Help - Search - Members - Calendar
Full Version: Speaker Issue
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mondeowolf
Hi, I have recently purchased a 2008 2.0TDCi Zetec, which has a few extra toys including bluetooth, voice control and 6 disc Sony head unit, having changed from a Renault Laguna this car is in a different class.

Only problem I have, is I noticed the other day that the rear passenger side speaker (woofer & tweeter) have no sound coming from them, I have had the door panel off to check all cables but these seem to be fine, wondered if anyone had any idea as to how I can resolve this problem??
jeebowhite
possible that they have outright blown, stick a multimeter on them see if there is any electrical current, if not, swap the spearker with a known working, see if the fault stays with the wiring, or goes with the speaker...
mondeowolf
Have taken speaker out and wired it up to home cinema and it was fine so appears speaker is working, therefore seems more likely to be problem at head unit end, any ideas anyone??
ppeter7
i take it you checked contacts where loom gose into the door itself??
mondeowolf
Pretty certain I did, although not to easy to check them fully as they have a rubber seal round them.
jeebowhite
best double check, it could be a lot less hassle than tracing the wires through...

I would start by taking the head unit out, and checking the cables at the connector, make sure theres no obvious seperation or breaks...
mondeowolf
That's my next port of call, day off work monday so i'll be taking head unit out to see whats what


Full Colour Version: Speaker Issue
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.