Help - Search - Members - Calendar
Full Version: St170 'lumpy' At 2000 Revs And High Revs On Start Up
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
brirob24
Hi all

My 2004 St170 is very slghtly 'lumpy' at exactly 2000 revs - feesl like a very slight misfire, also it over revs on tickover to approx 1500 rpm on a cold start (soon goes back to normal after a few miles).

does anyone have any suggestions before i start paying (i'm thinking of getting it computer tuned anyway). I'm thinking the lumpiness may be plugs or HT leads??

Thanks everyone
artscot79
can be a multitude of things high idle is related to the pcv valve and the idle control valve from cold it should sit around 1200 for a few minutes thats normal a slight misfire is either leads coil pack or plugs most will change all at once as if its the plugs and you put on a new coil the misfire will knacker the new coil also that ford hates aftermarket leads so only genuine ford ones will do a cheap try is to remove each lead and place a smear of vaseline on the plug then refit the lead
FOCA
They are bad for that, you could change the plugs, coil packs etc without any improvement (ive read on other forums people replacing practically everything without change)

Go ahead and change the plugs, because these are a "service" item anyway, you could upgrade them to NKG irridium (if not fitted already) make sure they are the right grade and correcty gapped as well

you may as well change the air filter and give it an oil/filter change

ist of all, the 1500 rpm tickover is probably the ECU setting it high to stap it "stalling", then when the engine is warmed up it drops down again - in other words, doing its job

the "flat spot" at 2000 revs is probably the intake trumpets moving, i don't know at what exactly what revs the variable intakes work, or if they work over a wide range (progressive) or work at a specific revs (like a switch) also the ST170 engine is a "highly tuned" naturally asperated engine, designed to give good power at high revs, the lift and duration of the cams, and the design of the exhaust are optomised to maximise power at the top end, normally, an engine like this would be useless at low revs, but the variable geometery intake trumpets help to boost the low end a bit but -

it needs to be vevved, 2k is very low revs for the ST170, did the car develop these symptoms or was it always like this?

ive just read the other post - yes the PCV valves can stick also the engine crankcase breathers can leak/ split over time - worth checking out
artscot79
the plug gap is 1.0mm the plugs you buy are pregapped wrong at 1.5mm so even this may be a cause if youve had them changed recently
brirob24
Thanks for all of the info, wasn't sure if [font="sans-serif"][color="#282828"]the 1500 rpm tickover was just the ecu doing its job, i just don't recall it doing it when i first got the car, maybe it does it more in the colder weather? I've had it about 3 months, also I don't recall it having the slight flat spot when i got it, but then recently I have been driving it at lower revs due to the weather. Looking forward to some slightly warmer weather so can start driving it 'properly' again! If it doesn't improve after its been having a decent amount of revs I'll change the plugs and HT leads (it had a recent air & oil filter change) or try Vaseline first![/color][/font]

[font="sans-serif"][color="#282828"]Thanks again[/color][/font]


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615