Help - Search - Members - Calendar
Full Version: Intermittent Electrics Problem
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
balloo

hi all ,joined up today on behalf of a freind with a mondeo tdci zetec and wondered if any helpfull souls can shed some light on the problems,sometimes all is fine but on ocasions when you turn the lights on firstly the speedo and rev counter do a sweep,no illumination of the spedo and rev counter,both indicator warning lights light up and stay on as does the high beam light !,and as far as i can understand the lights are on full beam and wont change to low,It can stay like this for a few mins or i think the longest has been a few days then all goes normal again !otherwise all else seems fine :blink: has anyone else had anything like this or any sugestions?thanks for taking the time to read and look forward to any help .all the best ;)

BigD

The dial sweep/all lights on is a classic symptom of a failing battery.  Any trouble starting?  Have you had a multimeter on the battery?  You should be showing about 14.4V.  There could be a bad earth somewhere but I have no idea where most of the earth points are.

 

Also, I assume the Mk4 needs a Calcium Silver battery like the Mk3 does.  Is that the type of battery he has, because if it is like the Mk3, then a normal lead-acid battery is no good.

balloo

 hi  :)  thanks for the reply  the car starts  o.k and works cool  in the day  ..its when you turn on the lights it goes bonkers will for sure have a check of the batterey many thanks ..chris



Full Colour Version: Intermittent Electrics Problem
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.