Help - Search - Members - Calendar
Full Version: Ford Fiesta Mk6 Aftermarket Stereo - No Power
Ford Owners Club - Ford Forums > General Forums > Audio & Electronics
apprentislawlor

Hello all.

 

I'm trying to fit a Sony MEX-BT3900u in a mk6 Fiesta 05.

 

The only way I can get power to it is if I connect both Red and Yellow wires at the stereo end to the Yellow at the harness end.

 

This means that the power is always on, even without the key in the ignition. Is there any way I can have it so it's connected properly i.e. key out=power off?

 

I've tried red to red, yellow to yellow and red to yellow, yellow to red.

 

The leads I bought are: http://www.amazon.co.uk/gp/product/B0043GWBBI/ref=oh_details_o02_s00_i00?ie=UTF8&psc=1

 

Is "always on" the only way to have it connected? I don't trust myself to remember to switch it off everytime I get out of the car.

 

thanks for having a look. 

dezwez

you can run a new wire from the  ignition switch but only conect it to a wire thats live in start and run

dead with key out the other wire in the harness is to keep the memory alive

DanGersFord
I fitted a Sony stereo and just bought a wiring adaptor from halfords and it turns on and off at the ignition no problem
apprentislawlor

Cheers for the replies. Nipped into Halfords and tried another harness but still no good. The lad there said that a piggyback off the fuse box is the easiest way, like @dezwez said.

 

Is it as simple as fitting one of these: http://www.ebay.co.uk/itm/2-Add-A-Circuit-Fuse-Tap-Piggy-Back-Standard-Blade-Fuse-Holder-ATO-ATC-12v-24v-/170709632237?pt=UK_In_Car_Technology&hash=item27bf1644ed

 

to something like the electric windows fuse, then running the wire to the red of the stereo?

 

Cheers again

MonkeyMattius

Hey John, 

 

I know i'm a tad late here but I have the JVC KW-AV60BT in my fiesta and the other day same problem, literally went no power. I went back to where I got it from after checking and testing everything I could and apparently they've had a couple do the same and they had to be serviced, despite coming back with no fault. 

 

Haven't got it back yet so I have a nice empty hole in my dash and a very quiet journey at the minute. As for the ebay item, message the seller and ask them if it is made for that purpose. Hope it gets sorted matey.



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.