Help - Search - Members - Calendar
Full Version: Service Oil Information Message - Help!
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Scandic18

The 'Service Oil' information message came on yesterday. I've now had the oil and filter replaced but the information message will not cancel.  I'd be grateful for any suggestions please.  (Mk4 Mondeo 2ltr 140 57 plate)

k13r4n
Ok bud what you do is insert key DON NOT TURN depress brake and accelerator pedals at the same time and hold now switch the car on but DO NOT start the engine watch the screen between Speedo and rev counter it will say resetting service light hold pedals down until complete. Easy as pie then turn your car off fire it up obv remove feet from pedals then the message shouldnt appear this was how I do it on my focus but it's a 2010 model but should hopefully be the same let me know how you get on
k13r4n
Ps mine is a focus as well but I would imagine it's the same
Scandic18

Worked it out!  Procedure below for others who may not know.

 

1. Get in car ensure all doors are closed.

2. Press both the accelerator and the brake pedal and hold them down at the same time.

3. Swith the ignition ON but do not start the engine.

4. Display will show message Service:Oil reset in prog.

5. Wait about 15 seconds - the display will show the message Service:Oil reset complete.

6. Take both feet of pedals.

7. Press OK to close.

8. Swith OFF ignition -  then ON again - message should have gone.  If not - repeat above procedure.

Scandic18

Thank you Keiran for your quick response. You replied as I was typing in the solution. Thanks again.

k13r4n
No problem looks like I was a tad faster on the keyboard :-)
tbw

Worked it out!  Procedure below for others who may not know.

 

1. Get in car ensure all doors are closed.

2. Press both the accelerator and the brake pedal and hold them down at the same time.

3. Swith the ignition ON but do not start the engine.

4. Display will show message Service:Oil reset in prog.

5. Wait about 15 seconds - the display will show the message Service:Oil reset complete.

6. Take both feet of pedals.

7. Press OK to close.

8. Swith OFF ignition -  then ON again - message should have gone.  If not - repeat above procedure.

does this procedure work with push start button?

Scandic18

Sorry, I don't know if it is the same procedure for the button start. Hopefully one of the other forum members can confirm one way or the other.



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.