Help - Search - Members - Calendar
Full Version: 1.8 Tdci Loosing Power!
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Damothire

Hi All,

 

I apologise if his has been discussed before, but I'll admit I'm a noob!

 

I've recently bought a 52 plate 1.8 TDCI focus with 180K on the clock. New cambelt at 170K. Seemed to drive fine, but as soon as you engage the turbo it stutters and the glow plug lights starts flashing. When that happens I tend to loose all turbo control all together and today I lost power when overtaking a lorry (quite scarry!).

 

I've taken it to a garge who chaged my fuel filter as they suggested the original was full of gunk. The car seemed ok for a few days without me using the turbo and driving sensibly, but the problem is still persisting.

 

I've got a horrible feeling the turbo is on the way out and don't really fancy paying out as much for a new turbo as I paid for the car. I'm going to attempt a minor service on it with a flush to see if this helps, but any suggestions from the experts would be appreciated.

 

Kind Regards,

 

Alex.

IINexusII

Take out the pipe going to the turbo and wiggle the turbo fan and see how much play you have

Damothire

I'll give it a little wiggle at lunch. Stupid question: how much play (if any) should you fan give?

focuscolin
If I'm right there should be no play , I had a problem with mine not long ago it turned out to be a split pipe causing a loss of power , I had a quick look on eBay and found a few company's who did a recon replacement turbo for 400 quid.
baitman

Hi All,

 

I apologise if his has been discussed before, but I'll admit I'm a noob!

 

I've recently bought a 52 plate 1.8 TDCI focus with 180K on the clock. New cambelt at 170K. Seemed to drive fine, but as soon as you engage the turbo it stutters and the glow plug lights starts flashing. When that happens I tend to loose all turbo control all together and today I lost power when overtaking a lorry (quite scarry!).

it might be that it is the EGR valve... 

mine felt like the turbo wasnt kicking in. it was ok at low revs, and when i opened it up or hit an uphill section and the car was under more load then the problem re-occured.

a much cheaper and easier fix than the turbo... best of luck, and report back soon  ;) 



Full Colour Version: 1.8 Tdci Loosing Power!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.