Help - Search - Members - Calendar
Full Version: 2001 1.4 Mk1 Ford Focus O2 Sensor Advice
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
badeye

Hi Guys,

 

So the car was misfiring on pot 2 for a few months, i replaced the plugs and all was better but it was still slightly misfiring. About 2 weeks ago the car had a massive giddy fit when i was driving up a dual carrageway, misfired like hell and the engine warning light came on. I have since rereplaced the plug, new leads and coil.

The car now doesn't misfire at all and runs great, good times!! however the engine light is still on. I read that the misfire can bugger up the O2 sensor, could this be the reason that the light is still on? I popped the bonnet today and removed the O2 sensor to see what state its in, i have attached the pics. Does anyone think i should replace this? does it look fubar?

 

Cheers,

 

Si

stef123

you need to check what the code(s) are and clear them and take it from there really. no point in replacing the sensor unless its knackered.

Also a live data scanner will allow you to see if it is switching correctly

artscot79
Did you have the original light reset if not it should have went off after 30 starts of the car personally ide have the code read and cleared first
wase16ll
you cant tell if sensor is bad just by looking at it im afraid.
chances are, that you just need to clear the fault codes triggered by the misfire, to extinguish the light.
either way, you need to access the code to see whats triggering the light, otherwise your just guessing, then clear them to see if light returns.
badeye

cheers guys, i do have an OBDII scanner so i'll use that to clear the codes and see if it appears again.

 

Cheers,

 

Si

badeye

Well i put new plugs in today and removed the O2 sensor and gave it a gentle clean to get all the carbon crap off it. I've just been and cleared the codes, fired up the car and left it to run to normal operating temp and all appears to be well. No light. Fingers crossed all is well now :)

 

Cheers Guys,



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615