Help - Search - Members - Calendar
Full Version: Hello And .......help....lol
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mondeotdci130

A week ago whilst driving/pulling out of a junction my coil light started flashing and i went limp

 

got home, turned engine off and back on.....fault gone

 

since then i get the flashing light on but after 2 miles i can stop/start and carry on with no problem, i drive 100 miles a day, 6 days a week

 

ive no smoke of any kind (except a bit under throttle - typical EGR valve)

 

ive changed the fuel filter, cleaned the MAF, cleaned out the EGR (which i had ri=un blanked off for 9 months)

 

the cars done 170K  (1ook of which ive done)

 

apart from the first 2 miles im getting good performance and 50mpg

 

any ideas?

 

i suspect the turbo actuator as once the arm is bolt upright after starting i get no problem but 1st start of a day the arm settle back a fraction

 

cheers

 

PS ive just got a Super-F lead and cd so i can read the errors codes soon

stooge75

ur not gonna know til you get codes read.cant see it being egr related tho as that shouldnt give you a flashing light,only a MIL light

mondeotdci130

486816_605809732765278_944332889_n.jpg

 

931155_605809816098603_82091934_n.jpg

 

936785_605809792765272_917530200_n.jpg

 

936365_605809969431921_1625806789_n.jpg

 

 

942956_605810022765249_1072785497_n.jpg

 

408494_605810062765245_1520187894_n.jpg

stooge75

your egr is maybe stuck. the 1328 code is a bit more daunting.maybe your injectors

what software is that?formidable? what cable can be used with it?elm?looks like your egr isnt opening at all if your cars idling(0mm).#

16kpa for map seems low also,no?(100 kpa in 1 bar i think)

FOCA

Did you take the EGR blanking plate off? best to stick it back on (solid, stainless steel plate)  

mondeotdci130

The EGR wont open under nil load anyway (car was at standstill), as with finding a split EGR pipe, you can rev it when not moving but drive it and the pipe comes under pressure

mondeotdci130

The fault is "Sticky variable vanes" i popped the turbo-actuator arm off and its very stiff, whacking it to/fro and spraying oil down the arm almost makes it OK

 

in garage on thursday for turbo decoke and im handing them an Innotec kit to use too

 

some use Mr Muscle!

 

http://www.talkford.com/topic/215546-turbo-housing-mod-for-p132b-fault/

FOCA

The EGR wont open under nil load anyway (car was at standstill), as with finding a split EGR pipe, you can rev it when not moving but drive it and the pipe comes under pressure

Best to blank the EGR valve anyway (solid, stainless steel plate) one less thing to go wrong/ will stop the inlet mnifold being contaminated etc etc  

 

Yes, the variable vanes get coked up and are a common problem on these cars, if the engine is producing extra smoke/ carbon, the vanes can get coked up quicker (for example if you run the car with the EGR unblanked)

mondeotdci130

Problem is the MOT tests will soon take an EML as an instant fail, so sooner or later you have to run the EGR working, if its been non-working and blanked for a year it needs a few hundred miles just to blow the cobwebs out although i van no clear rhe EML light with the Formidable

FOCA

Problem is the MOT tests will soon take an EML as an instant fail, so sooner or later you have to run the EGR working, if its been non-working and blanked for a year it needs a few hundred miles just to blow the cobwebs out although i van no clear rhe EML light with the Formidable

I presume you mean "i plan to clear the EML light with the Formidable" on the last part of your post?

 

the EGR  does not need a few hundred miles to "blow the cobwebs out" every second the EGR is unblanked it is contaminating the inlet manifold etc, so the reverse is true  

 

Yes, the UK MOT will fail a car with the EML on now, but thats just the day of the test (not the day before, or the day after)

 

The EML coming on seems to be a problem for the euro4 Mondeos, and not euro4 Focuses or any euro3 Ford (diesels)

 

Is your EGR still blanked now? / if so, how long was it unblanked?

stooge75
The egr WILL open when cars at standstill at idle by the way. Formidable needs fsuper cable to work properly. If u have elm cable try pcmscan-really good prog,& its there to be found for free if you look online
mondeotdci130

I presume you mean "i plan to clear the EML light with the Formidable" on the last part of your post?

 

IF ITS BEEN BLANKED AND I HAVE AN EML ON


 


the EGR  does not need a few hundred miles to "blow the cobwebs out"
every second the EGR is unblanked it is contaminating the inlet manifold
etc, so the reverse is true  

 

THE PIPE FROM THE TURBO MUST GET INPUT EVEN WHEN BLANKED, SO IT NEEDS TO CLEAR THAT CRAP


 


Yes, the UK MOT will fail a car with the EML on now, but thats just the day of the test (not the day before, or the day after)

 

THE EML ISNT A FAIL YET BUT SOON WILL BE


 


The EML coming on seems to be a problem for the euro4 Mondeos, and not euro4 Focuses or any euro3 Ford (diesels)


DIFFERENT ENGINES, DIFFERENT EGR

 


Is your EGR still blanked now? / if so, how long was it unblanked?

 

BLANKED 18 MONTHS, UNBLANKED 2 WEEKS

 

i CAN PULL THE VACUUM PIPE OFF IN SECONDS TO PROVE THE EGR

 

 

IVE CHANGED CAM SENSORS, CLEANED THE MAF SENSOR, NEW FILTERS, AND RUN IT IN MY TENURE FOR 100,000 MILES, ITS HAD DMF/CLUTCH/STARTER/AUX BELT+TENSIONER, WATER PUMP, AND MANY SUSPENSION BITS DUE TO POOR ROADS (IN GENERAL)

 

ITS HAD AN INJECTOR KNOCK AT JUST THE LOADING POINT (AS PULLING AWAY) WHICH DIMINISHES IF I PUT FORTE DIESEL TREATMENT IN, IVE FILLED UP WITH SHELL NITRO AND ADDED MILLERS THIS TIME

 

COST ME £4250 TO BUY, ABOUT £2000 TO KEEP RUNNING, WORTH ABOUT £1750 NOW, ON 170,000 COUNCIL WONT LET ME PLATE IT AFTER 200k

stooge75

did you get eml cleared?

mondeotdci130

The EML was on due to the blanked EGR, after 10 miles unblanked it goes off anyway but ive also cleared the code (for EGR) using the F super 150

stooge75

good good. I have a good few apps on my iphone that can be used with elm327 bluetooth nowadays. got em free from appcake as well. now that the famous roqybt4 bluetooth programme has appeared online(for nothing if u know where to look).

I have Rev,Dashcommand etc. theyre quite good apps!(ALL FREE!!LOL)

I just throw my bluetooth elm327 into glove compartment,when i need it,plug it in,start roqybt4 app,then start dashcommand,& clear codes etc till my hearts content. gives info on PID's & live data etc.(like it a lot)

steesh

Did you ever get to the bottom of the limp mode?

mondeotdci130

99% certain its the variable vane unit (in the centre of the turbo)

 

the arm from it to the actuator should be free and floppy, its sticky and rough

 

sprayed loads of penetrating oil down it, waggled it for 20 minutes and it was ok - for a while

 

filled with shell nitro+millers and yesterday it started up (no coil light/no limp) did 8 miles full welly, no probs

 

its in the garage for a turbo decoke today

 

cheers

steesh

Nice one, might mention that to the garage when i go on monday because mine has the same issue

mondeotdci130

with mine ---

 

start up and get coil light/limp mode

 

drive 2 miles, stop restart and light goes off, stays off unless i welly it

 

you wont have the electronic actuator

 

http://www.talkford.com/topic/214791-here-we-go/#entry1992457

steesh

Is that because of the age of my car? So your fix wont fix mine then

 

 

Mine...

 

Happened when i first bought the car, gave it a boot and it went into limp mode, took it back to where i bought it and ran a diag on it whereby it didnt actually go into limp mode but said there was a fuelling issue so they replaced the fuel filter.

 

Didnt happen again for a week then happened again when i was in outside lane of dual carriageway, put my foot down in 6th cos a car was zooming up my rear, straight into limp mode, had to pull onto hard shoulder

 

had another diag done, said something about the fuel rail? not sure what he said because i was actually in the garage for my temp issue so a wasnt listening lol

 

First diag had about 6 or 7 things that came up, one was a fault where it was saying my tank was empty so no fuel to engine, no injector faults tho.

 

Ive heard this issue is quite common and there is no one fix for it, trial and error i suppose but i love the car so i shall put up with it for now

mondeotdci130

get a reader, £20 for f super if you have a laptop

 

did they tell you the codes?

mondeotdci130

you wont have the electronic actuator but but you will still have the vanes, you have a vacuum actuator

 

and you have a non-sensor EGR so blank it off....

steesh

Aye but i didnt make a note of them, there were two, how do you use these reader things? I take it you can get em on ebay

mondeotdci130

yep

 

if you have a laptop

 

comes with software, i diagnostic costs £40 plus vat so your quids in

 

yours is a Tdci not a Tddi? a 53 tdci may have less functions and a Tddi has no injector codes

mondeotdci130

936785_605809792765272_917530200_n.jpg

 

408494_605810062765245_1520187894_n.jpg

 

942956_605810022765249_1072785497_n.jpg

steesh

Ive ordered one, i take it this lets you clear the eml light after blanking the egr?

mondeotdci130

look at your EGR

 

if it has no WIRES off it you wont get an EML come on

 

the super f does cancel an eml tho

mondeotdci130

yours should be like this

 

pull the small rubber tube off, stick a screw in it

 

job done

 

6t0m5t.jpg

mondeotdci130

you can clean out the EGR and inlet manifold in about 90 minutes, get gloves, a bucket, solvent, a babys bottle brush

 

shitty job

 

3749299739_9c26d798a8.jpg

 

969800_613693198643598_570309190_n.jpg

mondeotdci130

all that stuff also travels into the turbo vane unit

 

hqdefault.jpg

steesh

I bet my egr looks worse than that, am toying with using some wynns egr cleaner first to loosen and shift some of the crud

mondeotdci130

dont bother, waste of money mate

 

6mm.8mm and 10mm spanners and sockets

 

plenty of cleaner - even petrol

 

sh1tty job tho

mondeotdci130

when you refit it tighten well the big hose clip under the EGR or it will blow off

steesh

That wynns stuff will shift some of the muck tho, especially in places i cant reach, will still be taking the egr off and cleaning it after ive used the spray.

mondeotdci130

nice day to do it all today....

stooge75
Dont take ur inlet manifold off 1st without buyin new gaskets from jaguar. Every other manifold i do doesnt like old gaskets put back on-just a word o warning lol.
And i agree,use petrol to shift the crud etc.
Remember to use torque wrench to put back on.(VERY important!!,or it'll sit warped)
steesh

nice day to do it all today....

 

If i wasnt at work :lol:

mondeotdci130

Dont take ur inlet manifold off 1st without buyin new gaskets from jaguar. Every other manifold i do doesnt like old gaskets put back on-just a word o warning lol.
And i agree,use petrol to shift the crud etc.
Remember to use torque wrench to put back on.(VERY important!!,or it'll sit warped)

 

Why would he buy gaskets from jaguar when hes got a Mondeo, might be the same engine but i bet Jaguar charge more, and I bet Ebay is even cheaoer....

 

http://www.ebay.co.uk/itm/Genuine-Ford-Mondeo-MK3-2-0-16v-Di-Tddi-Tdci-Gasket-Set-Exhaust-Manifold-/230948992644?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item35c5a1f684

stooge75
Ive been buying parts from jaguar for mondeos for 5 yrs every other day. Jaguars' always cheaper than ford. & theres a reason why we buy essential items that are oem rather than cheaper stuff.and thats the wrong part your advertising-think he'll find it interesting trying to fit that on his IM. Youre needing inlet manifold gaskets x8. As i said,goto jaguar mate,theyre roughly £14 for a set of 8. If u buy from ford,theyre about £30 odd quid. Ebay does sell em but theyre total rubbish & arent as good quality as OEM.
The rubber gaskets on some ebay places are very stiff & dont sit great,compared to jags/fords
mondeotdci130

i did my EGR and manifold 80,000 miles ago and had no probs, BTW that ebay link is a Fraud dealer i think

mondeotdci130

Ive been buying parts from jaguar for mondeos for 5 yrs every other day. Jaguars' always cheaper than ford. & theres a reason why we buy essential items that are oem rather than cheaper stuff.and thats the wrong part your advertising-think he'll find it interesting trying to fit that on his IM. Youre needing inlet manifold gaskets x8. As i said,goto jaguar mate,theyre roughly £14 for a set of 8. If u buy from ford,theyre about £30 odd quid. Ebay does sell em but theyre total rubbish & arent as good quality as OEM.
The rubber gaskets on some ebay places are very stiff & dont sit great,compared to jags/fords

 

I wonder where Ford get them from cos Ford dont make many parts themselves....

stooge75

thats besides the point,its for an exhaust manifold. He needs inlet manifold gaskets(x8 of). we're talking about 2 totally different things.unless you put those on your inlet manifold.

& when you goto Jaguar you'll notice it has Ford/Jaguar on the bag.I know ford dont make parts.Ford get them from the same place Jaguar does.You get in touch with that seller & ask him how much his INLET-MANIFOLD gaskets are & I guarantee you,theyre not as cheap as Jaguar can sell em at.

Have you got something against Jaguar?

mondeotdci130

I must be lucky or good then cos i reused the old ones

FOCA

I must be lucky or good then cos i reused the old ones

+1 mine were fine too (both sets from 2 inlet manifolds), i think the carbon/ oil (from the breather) eats away at them and if the EGR is blanked/ breather is diverted they probably last a long time

 

I suppose it helps that you don't wreck them by torquing them down too much!  (they are thick rubber- they dont need much torque)

 

I just gave them a wipe to clean them and put the old ones back on - no problems (and i run upto 30psi)    

stooge75

I have to own up & say i torqued em up too much once & kinda ruined two o em,so my bad on that 1 lol

I wont even mention the torque I put the original ones back on with. :unsure:

mondeotdci130

I have to own up & say i torqued em up too much once & kinda ruined two o em,so my bad on that 1 lol

I wont even mention the torque I put the original ones back on with. :unsure:

 

Jaguar parts dept must love you

steesh

I'm going to bung the vacuum pipe and stick some egr cleaner through first see what happens

stooge75

im curious to know if oil stat fixes it.let us know

steesh

im curious to know if oil stat fixes it.let us know

 

will do, it will be tuesday when i get it done



Full Colour Version: Hello And .......help....lol
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.