Help - Search - Members - Calendar
Full Version: Mk2 Mondeo TD lack of boost
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
TurboZed
Hi Guys!
Just bought a Mondy Mk2 TD ghia estate. The car is fine except it feels like the turbo isn't boosting. Theres no smoke at all and no misfiring, just no power. A common easy fixable problem?
Cheers
Jim
rickb
[quote name='TurboZed' post='16905' date='Mar 28 2009, 10:46 PM']Hi Guys!
Just bought a Mondy Mk2 TD ghia estate. The car is fine except it feels like the turbo isn't boosting. Theres no smoke at all and no misfiring, just no power. A common easy fixable problem?
Cheers
Jim[/quote]
sounds like a siezed turbo bearing,the turbo proberly isnt spinning at all,hence no power no smoke,remove the turbo induction pipe and see if you can turn the turbine....hope this helps, turbos can be bought from most breakers for 30.....
rickb
[quote name='TurboZed' post='16905' date='Mar 28 2009, 10:46 PM']Hi Guys!
Just bought a Mondy Mk2 TD ghia estate. The car is fine except it feels like the turbo isn't boosting. Theres no smoke at all and no misfiring, just no power. A common easy fixable problem?
Cheers
Jim[/quote]
sounds like a siezed turbo bearing,the turbo proberly isnt spinning at all,hence no power no smoke,remove the turbo induction pipe and see if you can turn the turbine....hope this helps, turbos can be bought from most breakers for 30.....
TurboZed
[quote name='rickb' post='17378' date='Mar 31 2009, 03:38 PM']sounds like a siezed turbo bearing,the turbo proberly isnt spinning at all,hence no power no smoke,remove the turbo induction pipe and see if you can turn the turbine....hope this helps, turbos can be bought from most breakers for 30.....[/quote]
Thanks RickB, I'll try that.
Jim
sr-performance
if your turbo's not seized see if you can borrow a boost gauge see if your actually getting boost. could be a few things, air leak on vacuum pipe, intercooler leaking, all will lose boost pressure.


steve



www.sr-performance.co.uk
TurboZed
Hi again,
I've pulled the car apart today to investigate the problem. The intercooler and its pipework are fine, the pipe from the turbo to the pump is fine, the one from the turbo to the wastegate actuator is fine, and the turbo turns quite easily by hand. However it only turns very slowly on tickover, plus on hard revving although there seems to be quite a draught coming out of it, theres no pressure, you can easily stop the airflow with the palm of your hand. The other thing is its very oily indeed. I suspect that its had it, but I suppose the wastegate could be stuck open? The EGR doesn't appear to be opperating either, so if thats stuck open will that cause the same symptoms?
Cheers
Jim
TurboZed
All fixed! the wastegate actuator arm had fallen off. Had to remove the manifold to get it though. Still a bit worried about the oil, but we'll see what happens.
Jim


Full Colour Version: Mk2 Mondeo TD lack of boost
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.