Help - Search - Members - Calendar
Full Version: annoying galaxy squeal
Ford Owners Club - Ford Forums > Ford Models > Ford Galaxy Club
topcarp2
i have a 96 plate 2.3 galaxy and for about a week now there has been a loud squealing coming from the fan belt..if i douse it in wd40 it stops immediately then comes back after about 5 minutes
this is the wierd bit...if i go through a puddle of water then the squealing stops immediately and i can carry on driving without any more noise,but as soon as the car has rested for a while its there again as soon as i start the engine,,, any ideas on the problem are more than welcome cos i'm pulling my hair out over this one ...thanks
Steve
Hi

Welcome

Sounds like it is one of two things

1. Fan belt s worn and needs replacing (can make a cheeping noise when worn)
2. Fan belt is too loose.

I reckon its the 1st option to be honest.

tip or you is to get a candle and when the engine is running rub it along the side of the belt. (PLEASE BE VERY CAREFUL OF HANDS)

A new belt will help.
topcarp2
got it sorted now thanks..took it to fords who said i needed a new auxilliary tensioner..then to a local garage who simply puta new belt on...dont have to have the radio on so loud now...lol...thanks for reply
Steve
glad you got it sorted ;)


Full Colour Version: annoying galaxy squeal
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.