Help - Search - Members - Calendar
Full Version: Can Anyone Help, With A Speedometer Problem
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
Southseacap

Hi, l have got a 54 plate Ford Focus zetec.

But l have a problem with the speedometer, when l'm driving, the speedometer stops working. lt did only happen once in a blue moon, but now it happens most days.

ls it just a sensor or the main computer?????

Lenny

[font='lucida sans unicode', 'lucida grande', sans-serif]Hi, l have got a 54 plate Ford Focus zetec.[/font]
[font='lucida sans unicode', 'lucida grande', sans-serif]But l have a problem with the speedometer, when l'm driving, the speedometer stops working. lt did only happen once in a blue moon, but now it happens most days.[/font]
[font='lucida sans unicode', 'lucida grande', sans-serif]ls it just a sensor or the main computer?????[/font]

Hi Thomas,
Welcome to the forum,
The new models such as yours operate on a CAN-BUS system its basically electronic signals sent through various parts of the car,
This means for your speedo it is not mechanically operated like cars used to be.
So the speedo needle is not directly connected to the speed sensor.

Resulting in it being one of two items either the sensor or the speedo cluster,

One way of finding out by yourself is:

If you look up on accessing ford secret menu,



You can access a digital speedo that will display in the centre screen between your tacho and speedo,
Drive the car with this digital speedo on display,
Then look at the digital speed reading when the needle drops.

If the digital speed also drops,
Then I reckon its your speed sensor that needs replacement.
But
If your digital reading stays constant while the speedo needle drops
Then unfortunitly its your cluster requires replacement.

Hope this helps mate,
Southseacap

Many thanks for the details, any idea as to where the motion sensor would be.

Today the needle dropped 3 times in just 5 miles, so it seems to be getting worse.



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615