Help - Search - Members - Calendar
Full Version: System Malfunction Help!!!!
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
andysvision

Hello everybody, has been a month now that i see a board masage : ESP SYSTEM MALFUNCTION.Has anyone suffered it?i have read in some places and people say it a 1400 usd cost damage.OMG do you know any cheapper solution?like buying a used part on ebay?Please help,i have power loose too,from this erro :(

jeebowhite

sounds more to me like an ABS sensor failure.

 

HAve you done the dashboard trick and seen any particular errors on there?

andysvision

No i havent,im new ford user,can you help me how it is done and if i have what you say,is it expensive?thanks

jeebowhite

turn your keys to the off position, press and hold the trip computer "reset" button if you have one. then turn your keys to the electrics only position, do not take your finger off the button. You should find that this leaves your miles traveled, but may reset the miles.

 

Then when it goes through and does its self tests, press the button to cycle through. You may find DTC's in there (random codes like D9001 or u9000 amongst others you may have P codes.

 

If you find any - let us know and we could help identify the problem...

andysvision

turn your keys to the off position, press and hold the trip computer "reset" button if you have one. then turn your keys to the electrics only position, do not take your finger off the button. You should find that this leaves your miles traveled, but may reset the miles.

 

Then when it goes through and does its self tests, press the button to cycle through. You may find DTC's in there (random codes like D9001 or u9000 amongst others you may have P codes.

 

If you find any - let us know and we could help identify the problem...

 

hello friend,i just did the test like you told me ,and i managed to go to DTC#00 sector and there was writen : NO ERRORS..how it is posible ?so i dont have a physical damage?

jeebowhite

Very odd, normally I would expect an error of some type to be there, but then again, the on board only queries certain codes.

 

Have you got / do you know of anyone who has a code reader? are you in a hurry to get the car fixed? if not, you could buy a code reader, which should give you more of an idea whats going on!

andysvision

yes i think im gona buy a code reader,i read your article and it was cool about the errror reader :) and i saw the bluetuth and the pc version of reader,but witch one you segest me any sugestion :) thanks

jeebowhite

Hi Andy,

 

Well it depends, if you were to get bluetooth for your computer, you may benefit more, as the bluetooth would be useful for transfers from phone, or other enabled devices, its more portable and you can sit the laptop on youir driver seat, and move freely, or drive around with no interference.

 

The USB are also good, but you are limited to the length of the cable, and hoping that the cable doesnt get in your way whilst your tinkering!

andysvision

ok Boss got it,im going for a bluetooth than :) but i have to wait some time for it to come :) i will post the error code as soon as i get it :)

jeebowhite

No worries, will see what comes when you get it :)

andysvision

No worries, will see what comes when you get it :)

 

Hello again Boss,still witing for diagnosis tool to come,but what i found today maybe the problem of my car.i was looking at the manuals that were inside my dashboard i found a paper witch basicly seems to be a diagnosis made by the preowner of the car it say this text:

 

 

Fault Code Memory

 

ABS-Anti Brake-Lock System

ABS/IVD Ate 2003-2007,Ford Focus

ISO15765-CAN

3M51-2C405-HB

 

Present DTCs:   --

Stored DTCs:     1

DTC History       --

Pending DTCs:   --

 

===========================================================================================

Code Description

===========================================================================================

C1288 Pressure Transducer Main / Primary Input Circuit: Circuit Failure

===========================================================================================

 

 

WHAT DO YOU THINK?

jeebowhite

seems like the issue has been resolved, if its not happening now, but I would expect the ABS light to be lighting up, not a system malfunction.

 

Have you got your code reader yet?

andysvision

No im waiting for it to come.no i am not having the ABS light on my board,and ABS functions well itryed it.The button that deactivates ESP doesnt work,and when i dift my tirens no esp light comes on my board.But how do you understand that this c1288 is fixed?

jeebowhite

the c1288 is a circuit failure, that will illuminate at best a warning light when the error occurs, so if it was active, you would have an error light (either ABS or brake light). so I would guess its OK, but once you get the code reader, you can clear the codes, and check them regularly and see if the code comes back

andysvision

the c1288 is a circuit failure, that will illuminate at best a warning light when the error occurs, so if it was active, you would have an error light (either ABS or brake light). so I would guess its OK, but once you get the code reader, you can clear the codes, and check them regularly and see if the code comes back

 

Hello Pro!Yes i have the esp light turned on all the time and today finalyy i went to  my friend service and i checked for he errors,and yes :( the c1288 is there i got that errro i it was undeletable :( the bad goes bedest,yesterday i had sime strange sound at around 1000-1600 RPM like sime kind of wistle and a little burning aroma so i diagnosed that too,my friend told me it is my ALTERNATOR and its about 300 euros,i am a little sceptic about changing it.Becouse it maby not broken becouse i get this strange noise only when i add acceleration,and not any noise when my car is neutral in 700-800 RPM do you understand me?What if is only its belt?Than i fear again that burning odore,i dont kow what to do any experience of this type?Thanks

jeebowhite

For the C1228 - http://www.ecutesting.com/ford_focus___c-max_abs_pump_mo.html that is a company who apparently rebuild the ABS pump as this is apparently where the fault lies.

 

If the alternator was dead / dying, you would see that the battery light remains permenantly lit on the dashboard, it could be a further indication though (if that light is not on) that your ABS pump is indeed the culprit of both issues.

andysvision

For the C1228 - http://www.ecutesting.com/ford_focus___c-max_abs_pump_mo.html that is a company who apparently rebuild the ABS pump as this is apparently where the fault lies.

 

If the alternator was dead / dying, you would see that the battery light remains permenantly lit on the dashboard, it could be a further indication though (if that light is not on) that your ABS pump is indeed the culprit of both issues.

 

Thanks for the link im going to ask them if they ship to Albania :) . as for the Alternator i dont know what really to do, becouse when i opend my hood and checked smelling,that burning odore came from the alternator area :( Im going to make a video tomorowso maby you hear the sound better and maby you can tel what it is :) Thanks for your everyday effort :) best FORUM EVER!

jeebowhite

do you have any red battery lights on the dash? that would show its not charging properly, but if it is smoking it could be a damaged wire as opposed to the alternator unit... The alternator really needs to be checked along with the wiring leading to it, and you need to pinpoint exactly where the smell is originating.

 

As for the ABS pump, there is plenty of evidence to suggest its the pump, however you have to be aware that there is a chance that the error is not that, so you need to decide if its worth the gamble and pay to restore that, but there MAY be a slight chance its not. So far 99% of what I have read leads to this, but just be sure that you are happy to take the chance and get back an already healthy pump and it may be elsewhere...

andysvision

Today Updat

 

do you have any red battery lights on the dash? that would show its not charging properly, but if it is smoking it could be a damaged wire as opposed to the alternator unit... The alternator really needs to be checked along with the wiring leading to it, and you need to pinpoint exactly where the smell is originating.

 

As for the ABS pump, there is plenty of evidence to suggest its the pump, however you have to be aware that there is a chance that the error is not that, so you need to decide if its worth the gamble and pay to restore that, but there MAY be a slight chance its not. So far 99% of what I have read leads to this, but just be sure that you are happy to take the chance and get back an already healthy pump and it may be elsewhere...

Today UPDATE

Ijust come from the CAR SERVICE,we removed the Alternator and im going to an ELECTROAUTO to test it and maby repair it,hope it repairs as the cheapest solution.As for the ABS pump i am definitly take the risk,but i just eamiled the if they ship to ALBANIA and still no answer :( maby thei wont ever see my mesage :(

jeebowhite

best bet is to give them a call to be honest.

 

Out of curiosity, why are you shipping to Albania? your location is London on your profile? lol

andysvision

:) no PRO i live in Albania,in my profile is London becouse i couldnt find ALBANIA LOCATION on registration,but my uncles live in London :) sorry for the bad info

jeebowhite

is alright :) I shouldnt think it is too much of a problem for them though, they may just charge you a bit more for delivery!

andysvision

is alright :) I shouldnt think it is too much of a problem for them though, they may just charge you a bit more for delivery!

 

TODAY UPDATE

Got my alternator removed from the mechanic and i went to the ELECTROAUTO they told me it was dead or it was probably on its final hours,so i went and bought another alternator so i made them a easy question why was my first one damaged,they told me probably from the diesel that came from changin the fuel filted that is just on the top of the alternator,hmmmm is it true PRO?Does Diesel or water damage the alternator?I was thinking if its true than FOrd made it to the top so we damage our alternator and get it replaced,i nedd advece.....Than we got replaced the alternator and the belts etc etc...than came a stresfull etape..the pump had got air like all DIESEL engines sucks..if they get air they make your life harder :( after 1 hour atemp we managed to sart the engine and wait for the air to go totaly,than i went to try the aceleration pedal and it was very weird,i added accelerat and it tooked the RPM's like after 1 sec i added accelerat and the RPM went down slowly.The mechanic added much accelerat like 5000 RPM and the gas pedal managed to get hmmmm normal i think,do you understand me,sorry for my bad english.Is this all normal wwhat happened?Do i have to make any computer installation or something becouse we got the battery unplugged and maby the computer system is formated?Im dummy on how this thing works thats why i do this kind of questions,i mean its the car like the PHONE,for example if i take the battery from the phone i propably have to set the time and date to it again,...annnddd one thing i made the SELF test and i got a A103 on DTC#01 how to fix it?thanks :)

jeebowhite

Quick google search indicates that the error A103 is "antenna not connected" does the radio seem to work ok?

 

As for the alternator, it stands to reason that if you had a faulty fuel filter, and you had some fluid leak to the alternator that could well cause the death of the alternator. Sometimes the designs of the Ford can go against it, as you see, you have issues such as these.

 

If the fuel lines ended up with air in them you may wish to check the fuel filter housing, it may be damaged (small crack or worse) if the car continues to have problems it may need to be replaced again.

 

The lack of response on throttle would suggest you may have an issue with a sensor, you can start by disconnecting the battery for half an hour, this should help to clear it out. You may need to reset the time and date on the trip computer / stereo, but this is all that should really need changing.

 

Dont worry, your English is very good for someone who is not a native speaker, I can understand what your asking (or at least I believe I do ;))

andysvision

Thanks Pro :) i dont think  i have a leaking fuel filter but i think it leaked on the alternator when we changed the fuel filter becouse we didnt ut any protection like any tshirt on the alternator when we changed the oil and fuel filter so i think this might be the reason,and i was thinking..is there any other part on the hood that i need to be carefull and not to leak diesel on it?



Full Colour Version: System Malfunction Help!!!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615