Help - Search - Members - Calendar
Full Version: severe electrical problem
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
runnerman
My 57 Titanium X 1.8TDCI had to be towed to garage last night cos immobiliser activated. I stopped because the ABS, EPS and handbrake warning lights came on and speedo and fell to zero whilst in motion. Three weeks ago Ford garage investigated intermittant constant illumination of ESP warning light but concluded nothing was/is wrong despite ordering but then not fitting a new sensor (computer said it had fixed itself, yeah right!) Green Flag initaially thought duff battery in remote but even spare wouldn't work. Anyone suffered similar? PS, I don't think A/C is working either!
craggy
[quote name='runnerman' post='18532' date='Apr 6 2009, 10:25 PM']My 57 Titanium X 1.8TDCI had to be towed to garage last night cos immobiliser activated. I stopped because the ABS, EPS and handbrake warning lights came on and speedo and fell to zero whilst in motion. Three weeks ago Ford garage investigated intermittant constant illumination of ESP warning light but concluded nothing was/is wrong despite ordering but then not fitting a new sensor (computer said it had fixed itself, yeah right!) Green Flag initaially thought duff battery in remote but even spare wouldn't work. Anyone suffered similar? PS, I don't think A/C is working either![/quote]

take it back if it's still under warranty and tell the sods to fix it , you do have rights as a consumer.
runnerman
It's been diagnosed today - main ECU to be replaced once it arrives from Dagenham! Main reason for my post - I've only had this thing 6 weeks and wouldn't expect such a major failure on a vehicle with 12,000 on clock, wondered if this is common.
SierraYankee99
As with all electrical components you get faulty ones. At least they are rectifying it for you.
runnerman
oooh sorry guys ...........
runnerman
[quote name='runnerman' post='18864' date='Apr 7 2009, 10:03 PM']oooh sorry guys ...........[/quote]

update - 2 weeks later and still off road waiting for ECU from Germany. Efficient eh!


Full Colour Version: severe electrical problem
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615