Help - Search - Members - Calendar
Full Version: When Put Head Lights On Engine Runs Really Rough, Help!!!
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
noahdom

hi thx for reading, the problem I am having is on my mk3 mondeo zetec 2.0petrol (duratec) whenever I put my normal driving lights on at night the ngine begins to run really rough and if I don't give it more revs will surely cut out. however I can have main beam, a/c, heating on full plus wipers and this makes no difference to engines normal operation. also speedo and rev counter acting erratically and sometimes goes off briefly. I would be so grateful if someone could shed some light on my problem, as cant really afford to use a garage this near to xmas.  thankyou, matt

jeebowhite

It sounds to me like a potential battery issue. Visit several garages and ask them if they do a free battery health check. Have it tested and see what they say. Is it sidelights? or is it dipped beam headlights that cause the erratic behaviour? It could indicate a wiring fault...

noahdom

dipped beam headlights, the side lights make no affect to the engine at all. I can have everything electrical on simultaneously apart from dipped lights and all is fine however if i just put the dipped lights on it causes the problem. could this still b a battery fault as i have a newish batt in garage i cud try. also engine management light comes on now and again since the problem started

stooge75

you really need to get those fault code/s read as it'll be a good pointer to what's causing it. do you know anyone with a code reader? or elm327 cable etc?

jeebowhite

It sounds like a wiring issue to me. Check the fuse boxes and ensure that they are both dry and there are no overheating wires.

 

Error codes are a good place to start, but right now, if you have a spare battery I would say there is no harm in fitting it to see if it makes a difference!

noahdom
Thx very much for the advice will try the batt tomoz an if that fails will look for a diagnostic report, will get bac to u. Again thx
jeebowhite

No worries :)

noahdom
Tried batt no luck there also cam sensor
Dan62

.



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.