Help - Search - Members - Calendar
Full Version: Please Help Guys And Advice
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
n1xsta
Hi guys need advice,

Brought a 2001 tddi 2.0 Mondeo Zetec the other day more as a project.

My turbo doesn't seem to kick in at all and the car seems really sluggish.

I am driving with my foot down and feels I'm driving a 1.0 engine in my big car. There is nothing at all it just goes up slowly. There is no misfiring or anything.

The car was used on a farm and have fixed the oil pressure switch and the rear wheel bearing hub will be doing a service On the car next week but this is my next mission.

Any ideas welcome please
mintalkin

check all the rubber hoses for signs of damage as this could cause a loss of boost,also check the sensor in the hose under the rad.

jeebowhite

Do you hear any weird whistles or whines when your foot is attached to the floor?

n1xsta
No I don't
jeebowhite

So it would appear that you dont have any cracks in the intercooler pipes or hoses. It sounds like the turbo might just be dead (presuming you have one!?)



Full Colour Version: Please Help Guys And Advice
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615