Help - Search - Members - Calendar
Full Version: black smoke
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
garmag
Hi to you all,

I have the usual problem with my 54 plate mondeo tdci in that i get a lot of black smoke when accelerating.I changed the egr valve last year which was a genuine ford valve brand new but was fitted through a friend so it is near impossible to take back to ford.
I only seem to get this problem when i accelerate in 2nd or 3rg gear and a plume of black smoke appears.

as the egr valve has been done i am wondering if the problem could be something else??

please help
SierraYankee99
Classic EGR symptoms mate. Get your mate to blank it off see what happens then.
garmag
ok thanks for the advice.Any ideas where i would get a blanking plate and what the procedure is to fit it
SierraYankee99
[quote name='garmag' post='21365' date='Apr 21 2009, 09:29 PM']ok thanks for the advice.Any ideas where i would get a blanking plate and what the procedure is to fit it[/quote]


Not something I've ever done mate. There could be other reasons, blocked air filter, engine needs a good thrashing to blow the cobwebs out especially if its only used on stop start short journeys.

Have a look on [url="http://www.fordmondeo.org"]Mondeo Enthusiasts Group[/url] cos I know they are slightly different on the Mondeo to the focus
bosnjo
Maybe just one more thing to check, simple one:
Check the tube that connects EGR valve and Intercooler. It cracks easily on all Turbodiesels and results in loss of power and black smoke.


Full Colour Version: black smoke
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.