Help - Search - Members - Calendar
Full Version: Battery warning light
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
im_mondeo
Hello,
I have a problem with my Ford Mondeo 2002 2Litre TDDI, The alternator in the vehicle failed and a brand new one bought from the Dealer was fitted by an electrician. Although the new alternator is charging and the car is running sound, I have the battery warning light that comes on about 20 seconds after I start the engine. I also noticed that when this light is on, the front heated windscreen doesn’t light up and function.

Almost 2 years ago, a new alternator was fitted in my car and I had same problem (I am a night time taxi driver therefore the alternator keeps failing due to electric surcharge). I took the car to the dealer and they found a fault in the wiring loom.....I was charged £245.

Any suggestion what this wiring loom can be?? any help will be very appreciated
hondacr250
[quote name='im_mondeo' post='21945' date='Apr 26 2009, 03:34 PM']Hello,
I have a problem with my Ford Mondeo 2002 2Litre TDDI, The alternator in the vehicle failed and a brand new one bought from the Dealer was fitted by an electrician. Although the new alternator is charging and the car is running sound, I have the battery warning light that comes on about 20 seconds after I start the engine. I also noticed that when this light is on, the front heated windscreen doesn’t light up and function.

Almost 2 years ago, a new alternator was fitted in my car and I had same problem (I am a night time taxi driver therefore the alternator keeps failing due to electric surcharge). I took the car to the dealer and they found a fault in the wiring loom.....I was charged £245.

Any suggestion what this wiring loom can be?? any help will be very appreciated[/quote]
hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.
hondacr250
[quote name='im_mondeo' post='21945' date='Apr 26 2009, 03:34 PM']Hello,
I have a problem with my Ford Mondeo 2002 2Litre TDDI, The alternator in the vehicle failed and a brand new one bought from the Dealer was fitted by an electrician. Although the new alternator is charging and the car is running sound, I have the battery warning light that comes on about 20 seconds after I start the engine. I also noticed that when this light is on, the front heated windscreen doesn’t light up and function.

Almost 2 years ago, a new alternator was fitted in my car and I had same problem (I am a night time taxi driver therefore the alternator keeps failing due to electric surcharge). I took the car to the dealer and they found a fault in the wiring loom.....I was charged £245.

Any suggestion what this wiring loom can be?? any help will be very appreciated[/quote]
hi i have a focus st170 and mine is doing the same as yours - changed alternator and light is still on. i have had a few people message me back with -a bad earth in the car? dodgy alternator and battery well mine is none of those. my car is in the garage at the moment to see if they can find the problem so ill let you know.
im_mondeo
OK, let me know
treblebob
Hi there
I've had this problem for a while now since my alternator failed(?)
My mechanic fitted a new alternator and the light stayed on although the battery was charging ok.
He then removed the new alternator and had it tested...all ok...light still on though.
He then thought possibly a fault with the lead connecting alternator to loom. Apparently ford dont supply this on its own, has to be with the complete loom..because there's a common fault with them.
So got a 2nd hand lead from scrapper, fitted but still the light is on.

that's where I am at...now thinking of trying to get another lead to try.

Have any of you got any further forward?

thanks
mintalkin
the three pin plug to the alternator are known to give trouble check that all the connections are ok, the light remaining on could indicate a fault in the smart charge system do a search for ford smartcharge and read all about it.
treblebob
i'm picking up another lead tomorrow to try.
If it is a fault with the smart charge system how do I get it rectified...will it be a ford job do you think?
sr-performance
can also be the live cable from alternator to battery +
if this has a break it can put light on


steve




www.sr-performance.co.uk
jocojohn
Hi, my son also had the same problem last year with his 1.6 T reg focus, namely the battery warning light would come on about 15 seconds after starting, even though the alternator was changed and was charging ok.

At first we thought it was the dreaded focus instrument cluster problem.

We finally traced the fault to a break in the small red wire from the alternator 3 pin plug to the under bonnet fuse box.

I dont know if the wiring is similar on a Mondeo but its worth checking all wires to the alternator with a multimeter for voltages, earths, and continuity.

John


Full Colour Version: Battery warning light
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615