Help - Search - Members - Calendar
Full Version: Escort Zetec Problems??
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
Series1Turbo
[b][color="#0000FF"][font="Comic Sans MS"]Hi All,

I own a 1.8Si Escort Zetec, it has a superchip and a fse boost valve, mention incase it a problem?, but she is misfiring and losing alot of water? I have changed most of sensors but have a feeling it could be head gasket? It only misses in low revs? As you put down accelerator. It clears higher up revs? Any help would be appreciated it had a new head gasket a year ago when head was rebuilt.

Kind Regards[/font][/color][/b]
Steve
when the car is cold.. have a sniff in the radiator/resevoir and see if it smell of petrol, also check for white gumk under oil and radiator cap

car must be cold.
jock0909
[quote name='Series1Turbo' post='752' date='Mar 13 2008, 02:04 AM'][b][color="#0000FF"][font="Comic Sans MS"]Hi All,

I own a 1.8Si Escort Zetec, it has a superchip and a fse boost valve, mention incase it a problem?, but she is misfiring and losing alot of water? I have changed most of sensors but have a feeling it could be head gasket? It only misses in low revs? As you put down accelerator. It clears higher up revs? Any help would be appreciated it had a new head gasket a year ago when head was rebuilt.

Kind Regards[/font][/color][/b][/quote]

Loosing water - from where?
If it is not visible - the leaking at the engine bay or inside the car, then the engine is using it.

is there white smoke or water dipping from the exhaust?
Is it difficult to start from cold or hot?


Full Colour Version: Escort Zetec Problems??
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.