Help - Search - Members - Calendar
Full Version: Hello
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
Blackmagic

Hi all,

 

Trust you are all well?

 

Names Carl, 28 and from Handcross, West Sussex.

 

Drive a 06 mk3 mondeo 2.2 tdci estate and a Honda CRZ. I have mainly joined because of a problem i am having with a car which ill describe in a new thread.

 

Hope someone can steer me in the right direction with this issue.

 

Thanks,

 

Carl

dezwez
Hi welcome :)
xdazx
Welcome whats up with car
Blackmagic

It all started when we had the floods recently. i drove through a puddle and the coil light started flashing and the car was then in limp mode.

 

Got home, switched it off and switched it back on and the car was back to normal.

 

It was a fairly intermittent fault but now its starting to happen on a daily basis.

 

The only patterns i am noticing is.

 

When under power pulling up a hill it goes into limp mode. (not all the time)

 

Also,

 

I can tell when it will go into limp mode because the fuel gauge will be showing a rapid fuel loss.

 

For instance: it will say 100 miles remaining then with in a few miles it will say 25 miles remaining. Then the coil light will start flashing, into limp mode. switch car off and on, then ill have 100+ miles in the tank.

 

Also,if the car has gone into limp mode alot during one day i find the engine management light comes on.

 

xdazx
My friends just had the same problem they ended up sending car back to finance ppl as was going to cost thousands to repiaire mind you theres was a jag with mondy engine.
You may have a leaking injector and few other things wrong. Ive just looked in my emails to try and find what they said was wrong with theres but i must of deleted it


Full Colour Version: Hello
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.