Help - Search - Members - Calendar
Full Version: Trouble Ahead?
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
thinker

Hi to you all,am hoping for some help here.

I have a mondoe 2.0 tdci,the problem started yesterday after fitting a new flexie pipe on the ehaust.

The dreaded glow plug light flashing away going into limp mode but ok after you switch engine off and then bck on again?Anyway my good lady uses the car for local runs (not good) so I thought I would take it for a blast to clear the soot away.Looking in my mirror I see sparks (burning soot?)coming out of the ehaust is this normal or is the cat gone and would that make the glow plug light flash putting it into limp mode.Thanks in advance.

xdazx
Hi welcome. Can you not take it back to were pipe was fitted and get thrm 2 check
thinker

Hi Darrell,took it bck this morning and everything ok so still at a loss,dont know what todo now.I have checked glow plugs,all ok,checked injectors,all ok,cleaned the egr,working ok,air mass flow sencer ok,gave it a oil and filter change,fuel filter as well,checked all rubber pipes for leakage from the egr to the turbo ,all ok,really stuck here now,oh and the reversing lights not working will check that tomorrow,dont know if that would put it into limp mode?Anything more I can do,just say and I will give it a go.Thanks for your speedy reply hope to hear from lots of you soon.

xdazx
Next best thing i can suggest is putting it on a diagnostic m/c to get fault code up and fund out that way tbh ?
thinker

Forgot to say that Darrell , had that done but no codes found,its a bloody pest trying to get to the bck of it that's for sure.

The limp mode just seems to come on at about 2-3 thousand revs,the car does not stop it just seems to lack power?I pull up at the side of the road turn it off and then on again and hey it drives and runs like a dream.Starting to think about another car(not ford) but just don't like being at a loss as to what is wrong.More help needed,thanks.  

xdazx
Did u check to see if any the injecters was leaking ?
mick85
Check fuel pressure sound like injection pump on way out wat diagnostic machine U use to check fault codes


Sent from my iPhone using Ford OC
thinker

Hi Darrell and Mick85

All injecter bodys are bone dry and it was a ford diagnostic machine I just pluged in.All came bck saying no code found and that was when the glow plug light was flashing.

Whats the best way to check fuel pressure?Look forward in reading your thoughts about it cos am at a loss.

thinker

Sorry lads forgot to say I have got a tin of purge to clean the injectors,do you think that would help?.

mick85
When u say u tested injectors did u do a leak off did u cut open fuel filter check for metal particles in fuel


Sent from my iPhone using Ford OC
thinker

Hi mick85,

Never cut open the old filter to check for metal particles and all I did was checked where the injectors goes into the engine,that area

was dry.Do you think I should use the purge cleaner for the injectors,cant do any harm eh?.

mick85
Can't do any harm u will need do a leak off test if u watch YouTube u can make up ur own leak off bottles an pipes really cheap this test is good place start first


Sent from my iPhone using Ford OC
xdazx
Have you sorted it ?
thinker

HI Darrell,

still no joy,cut open the old fuel filter and found nothing but clean fuel ? and Went away and got a new erg and fitted it  thinking it would help,no joy.Spoke to a engineer and he said it could be the veins on the turbo sticking?but I don't think so, for the simple reason is the car goes great once I turn it off and bck on again so thinking if the vains are sticking the limp mode would be on all the time.(starting to cry now lol)) so really don't know.Is there any sencors that could be causing this,any help would be great.Thanks in advance.

xdazx
Did u do that leak off test ? Cus idol mode like u have described the poss causes are most off what you said so its got everyone baffeled i think.
thinker

just away to look it up on youtube and will let you know how it goes Darrell,thanks.

thinker

Thanks lads for all your info.

Had to go to Glasgow at the weekend,done about 338 miles and hey :D the car seems to be going just fine,no more glow plug light and no more limp mode(hope it stays that way(falling in luv with her again lol).

Thanks again.

xdazx
What did you do to it in the end bud


Full Colour Version: Trouble Ahead?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615