Help - Search - Members - Calendar
Full Version: Rookie Ford Enthusiast (Indicator Problems)
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
Crikky22

Hi Guys!!

 

I am new to the world of Ford, having previously owned a 106 Quiksilver, Punto and a Classic Austin Mini City, I thought I would land myself a tidy little Ford Fiesta Flight mk5. I was blessed with this little beauty at the start of 2014 and have had no problems so far!!

I am a level one mechanic. However, I am not so good with the electrical side of things! My o/s front indicator has started repeating rather fast, yet all the others seem repeat at the standard speed....if anyone could pass on their wonderful knowledge of all things Ford electrical, I would be very greatful!!

 

Also, as stupid as it may seem that I want to modify this car, what are peoples thoughts and suggestions? It's a black standard mk5 flight.

 

Thanks in advance guys :)

dezwez
Hi welcome :)

check al the indicator bulbs on the side its on one is dead that's what make it flash faster
Crikky22

Hi Derek, 

 

Thank you for a fast reply!

A very interesting answer, I hadnt thought of that one. I will have a look and hopefully sort it, thank you for that!  :)

 

On the subject of lights, my partner and my dad keep telling me that me n/s tailgate light doesnt work when I have either side lights or main beam lights on, but whenever I look they all seem to be working fine! Could this be some sort of loose/dodgy connection do you think??

 

Thanks :D



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.