Help - Search - Members - Calendar
Full Version: Ford focus 1.8 zetec 1999
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Paul focus problemo
Hello everyone !

I have recently put new brake pads on the front of the car and was a really easy job to do no problems at all !! then there was the rear brake pads ahhhhhh!!!!!!!! nightmare.
Basically the haynes book says that you can wind the rear brake pistons back in with long nose pliers unfortunatly that was not the case, anyhow i now have a rewind tool on order and will do the rears when the tool arrives. One week later and the abs and track control light came on and stayed on.
I did have a little brake fluid leak from the brake fluid pot when i pushed the front pistons back in and it would have dripped directly onto a electrical connector beneath however it seems to be dry to the touch.

Does anyone have any clues as to why the lights may have come on and what tests can i do to trace this problem. It did take 1 whole week for the lights to come on so you would think it was related to the work i have done however it seems likely.
My only thought was that the fluid has got into that electrical connector and made a short ?

Over to you guys !!!

Please help me its driving me mad

Cheers
hotashel
Hi,

I got WD40 on our rear ABS sensors and the light stayed on while the car was still jacked up but as soon as I drove it the light went out straight away.

H
old cruiser
I would be inclined to remove this connector and dry it out, if you have any brake or carb cleaner to hand you could use that to spray in there to remove the fluid and then it should evapourate leaving it dry.
Cheers Pete


Full Colour Version: Ford focus 1.8 zetec 1999
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.