Help - Search - Members - Calendar
Full Version: Mondeo misfiring at low revs
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
BlueHuman
Hello, some advice if I may please Ė I own a Mondeo 2004, 1.8 petrol thatís done a genuine 50k; itís starting to misfire at low revs [hot or cold] up to about 1500rpm.

I donít believe the plugs / HT leads have ever been changed and thatís where I need some advice Ė Iím getting conflicting direction when they need / should have been changed, as apparently this may be the cause of the misfire.

This morning I was going to replace them myself but after going to my local TOMO they are costed at £110 for the bunch and I wasnít expecting them to be that expensive.

Can anyone confidently state when the plugs need replacing and do you think this could be the cause of a misfire?

Thank you - Blue
mintalkin
if the leads are starting to break down(common on mondeos) a weak spark will be the result, before buying new plugs leads ect try gapping the plugs at 1mm instead of the recomended 1.3mm to see if there is an improvement.
BlueHuman
[quote name='mintalkin' post='30715' date='Jun 27 2009, 04:19 PM']if the leads are starting to break down(common on mondeos) a weak spark will be the result, before buying new plugs leads ect try gapping the plugs at 1mm instead of the recomended 1.3mm to see if there is an improvement.[/quote]

Thanks for that - I'll give it a go later to see if it helps.

Blue
The Gardener
[quote name='mintalkin' post='30715' date='Jun 27 2009, 04:19 PM']if the leads are starting to break down(common on mondeos) a weak spark will be the result, before buying new plugs leads ect try gapping the plugs at 1mm instead of the recomended 1.3mm to see if there is an improvement.[/quote]


I had same problem which turned out to be the coil pack.
My friendly local moto shop let me borrow ht leads and as this made no difference i put in new plugs still making no difference.
Then a banger racing friend of mine suggested the coil pack, 'about £50 off e/bay' and after fitting, this cured the problem.

Hope this helps

Simon
BlueHuman
[quote name='The Gardener' post='30754' date='Jun 27 2009, 08:42 PM']I had same problem which turned out to be the coil pack.
My friendly local moto shop let me borrow ht leads and as this made no difference i put in new plugs still making no difference.
Then a banger racing friend of mine suggested the coil pack, 'about £50 off e/bay' and after fitting, this cured the problem.

Hope this helps

Simon[/quote]

I'll try the plugs and leads first and then if no joy, I'll go for the coil pack.

Thanks Simon - Blue


Full Colour Version: Mondeo misfiring at low revs
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.