Help - Search - Members - Calendar
Full Version: Ford Fiesta Juddering
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
forumguy
Hi all, I was wondering if you could help me. Recently when accelerating rather hard, the car judders a little around 1500-2000 RPM. This is usually in second gear and if I keep accelerating hard it can occur into third as well. If I ease off the throttle it can disappear and easy accelerating is OK. It can judder up hills as well, I try to keep the throttle still until I get to the top. I had the car properly serviced. At first I thought that the clutch was gone, but the mechanic tested the clutch and said that it worked fine and that a service and new spark plugs were probably needed. After the service the mechanic tested the car and found the issue was still there and replaced the ignition coil with a working ignition coil that they had in stock (used?). He had it fitted and said that the issue was sorted. I drove away and a day later I felt the car judder again, but not as bad as before. Instead of lastly for 3-4 seconds, and maybe up the gears it would occur for a second and occasionally juddered.

I've read the comments below and my only concern is that the ignition coil was replaced and the issue remains. Whether the replaced ignition coil that was used is the problem, I'm not sure, but has anyone got an idea of what else it could be and the likely cost?

Maybe I'm being paranoid but the car doesn't pull like it used it either. Could I be misfiring and running on 3.5 cylinders? Or is it a problem with the sensor and replacing it with a new coil.

I was thinking of taking it to a proper Ford garage so they could hook the car up to a diagnostic machine but again its likely to be expensive, with no 100% guarantee of success.

I'd appreciate any help, because my trusted Fiesta has been great to me so far.


Previous comments to other poster's problems..
>>
Coilpacks seem to be a recurring problem. Have a read of some of the other threads re Focus misfires. <<

>>thanks for your help on the issue.i have since had the car back in the garage and it has had a new set of leads and also a new sensor. not sure what the sensor is for but everything seems to be working fine.<<
mintalkin
it does sound like a missfire problem which is usually down to plugs, leads or the coil pack. fiting secondhand parts can be risky as you do not know how good the parts were to begin with.
jim0231
ive got the same sort of problem, for some unknown reason it jus developed slight 'jumps' when accelerating not sure what it is, ive change the plugs......maybe i thought fuel filter?
ive got a mk4 fiesta 1.25 zetec.
gaz6076
[quote name='jim0231' post='33333' date='Jul 18 2009, 11:58 PM']ive got the same sort of problem, for some unknown reason it jus developed slight 'jumps' when accelerating not sure what it is, ive change the plugs......maybe i thought fuel filter?
ive got a mk4 fiesta 1.25 zetec.[/quote]

Since you've already changed the plugs I would say it's either the coil pack or the leads.
jim0231
[quote name='gaz6076' post='33369' date='Jul 19 2009, 02:01 PM']Since you've already changed the plugs I would say it's either the coil pack or the leads.[/quote]

yep, spot on, i bought some HT Leads, changed them......job's a gudden.


Full Colour Version: Ford Fiesta Juddering
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615