Help - Search - Members - Calendar
Full Version: Focus 1.6 Zetec - DS Window & Blowers Not Working
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Nick_Zetec
Hello there,

I recently have just bought a MK1 1.6 Zetec Auto which Iím extremely happy with. The car has done a few miles but drives like new as it has been wonderfully looked after.

Anyway there are a couple of issues that Iím hoping that you can put me straight on, firstly my driverís side electric window isnít working. I have checked the fuses but they are all ok, the strange this is that the passenger side works no problem. What could this be down to?

My second problem is that my blowers arenít working either, now Iím not sure but I understand this could be down to a regulator in the glove box and pointer here would be greatly received.

I look forward to some replies,

Nick
mintalkin
the window problem could be down to a faulty switch, damaged wireing at the door pillar or a dodgy window motor.
with the blower have you checked the fuses and relay for it ? if the resister pack was playing up you would usually get at least one speed from the blower motor usually the higest speed. if everything checks out it could be a dodgy switch.
Whelk8891
Window: The two main likely causes would be either a faulty switch, or a faulty window motor. My money would be on the motor at this stage.

Blowers: Do they work on #4? Or not at all? If they only work on #4 then its the thermal resistor, which can be found behind the glove box, next to the heater motor housing. About £15 for the part - dead easy to replace. If its not working at all, then you could check the multiplug is properly pushed into the heater motor (this involves removing some bits of trim and standing on your head almost in the passenger footwell).


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.