Help - Search - Members - Calendar
Full Version: Aircon/fuse box
Ford Owners Club - Ford Forums > Ford Models > Ford Galaxy Club
hedgario
Hi, I'm new to this site and have aproblem with the aircon on my x reg ford galaxy. I took it to a Kwik Fit for a re-gas which, according to the print out, was fine, no leaks etc. The air-con was still not blowing cold air and the mechanic suggested it may be a fuse that needed replacing as the compressor was not clicking and rev counter not moving. Is this likely?
Unfortunaltey, the fuse box cover is missing and I'm unsure which fuses to check

Any help would be greatly appreciated !

Thanks in advance !
Air Hostess
[quote name='hedgario' post='33051' date='Jul 15 2009, 10:15 AM']Hi, I'm new to this site and have aproblem with the aircon on my x reg ford galaxy. I took it to a Kwik Fit for a re-gas which, according to the print out, was fine, no leaks etc. The air-con was still not blowing cold air and the mechanic suggested it may be a fuse that needed replacing as the compressor was not clicking and rev counter not moving. Is this likely?
Unfortunaltey, the fuse box cover is missing and I'm unsure which fuses to check

Any help would be greatly appreciated !

Thanks in advance ![/quote]

I had this problem when I had an Astra.exactly the same symptoms, turned out to be the wire connecting the relay to the compressor had come off (at the compressor end),under the bonnet have a look and a feel around ,see if you have any loose wires if that makes sense but cant tell you which wire/fuse you need to check hope that helps a little at least worth 10 mins investigating

Kristal


Full Colour Version: Aircon/fuse box
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.