Help - Search - Members - Calendar
Full Version: running problem
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
FF87
I have a 1999 Focus ZetecS it had developed a fault of over reving and holding the revs high when i come to a stop, its had 3 idle control valves and has been the same with everyone of them, Could anyone shine some light on this for me?
Owen J
[quote name='FF87' post='35702' date='Aug 2 2009, 04:25 PM']I have a 1999 Focus ZetecS it had developed a fault of over reving and holding the revs high when i come to a stop, its had 3 idle control valves and has been the same with everyone of them, Could anyone shine some light on this for me?[/quote]

Is your throttle cable frayed? Sounds a bit of a longshot but that sounds like similar symptoms to my mates car and that was the problem then........
mintalkin
also look for any split or damaged rubber pipes that could allow into the manifold.
FF87
will get both looked into when i get my car back, it died completely on my stepfather on the motorway this morning :blink:
sTu III
[quote name='FF87' post='36709' date='Aug 10 2009, 10:56 AM']will get both looked into when i get my car back, it died completely on my stepfather on the motorway this morning :blink:[/quote]

Check your MAF sensor too. I had this problem with my old Escort. Was quite embarassing when I pulled up to roundabouts and my car was revving its nuts off! :lol:


Full Colour Version: running problem
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.