Help - Search - Members - Calendar
Full Version: mk3 electrics
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
sooty
hi,

i have a 2006 tdci estate, having trouble with the rear 12volt socket in the luggage area. have checked it out but no power. where is the fuse for it and any one having the same problem . can anyone suggest a repair. as you can tell not really into electrics.

thanks

sooty
mintalkin
it should be f70 - 15amp in the glovebox fuse box.
sooty
[quote name='mintalkin' post='45003' date='Sep 30 2009, 08:42 PM']it should be f70 - 15amp in the glovebox fuse box.[/quote]
sooty
thanks mintalking,

will find it out , is this a regular problem or is it just a rare occasion ? and should i be looking for anything specific that would cause the fuse to blow ?

sooty
mintalkin
if the socket was overloaded that would cause the fuse to blow, it could be a one off occasion these things happen.
sooty
[quote name='mintalkin' post='45194' date='Oct 2 2009, 06:52 PM']if the socket was overloaded that would cause the fuse to blow, it could be a one off occasion these things happen.[/quote]

thanks mintalkin,

will check out fuse, have haynes manual , it says fuse is also for instrument panel and its ok , but hey what do they know.

sooty


Full Colour Version: mk3 electrics
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615