Help - Search - Members - Calendar
Full Version: Few Problems...
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
pezza
Hi guys, I'm new to these forums but wondered if you could help me out with a few things.

I have a W reg mk5 fiesta.

It all started a few days ago when the exhaust screwed up. Part of it was literally hanging off the car. I took it too one garage and they quoted a whole new exhaust. Took it somewhere else and they claimed all I needed was a new Cat Convertor. After agreeing to this and paying 200 I drove the car home. Once I got home i noticed something leaking from the bottom of the car. It certainly wasnt oil and so I figured they'd topped up my washer liquid as I new that had a leak in.

The next day I took the car out and suddenly the red temperature guage came on and off every few minutes. After arriving home I noticed there wasnt a drop of coolant in the coolant tank and so im guessing this was causing the overheating. It was also making a very loud rattling noise when revving just before I got home.

Do you think the garage have caused a leak? I've checked the oil and its still a dark black, and Im pretty sure it's not mixing with the coolant. I'm taking it back to the garage tomorrow.

Shall I just fill the cooling system with distilled water for the drive there?

Thanks a lot

Alex
rickyp
[quote name='pezza' post='45337' date='Oct 4 2009, 08:54 PM']Hi guys, I'm new to these forums but wondered if you could help me out with a few things.

I have a W reg mk5 fiesta.

It all started a few days ago when the exhaust screwed up. Part of it was literally hanging off the car. I took it too one garage and they quoted a whole new exhaust. Took it somewhere else and they claimed all I needed was a new Cat Convertor. After agreeing to this and paying 200 I drove the car home. Once I got home i noticed something leaking from the bottom of the car. It certainly wasnt oil and so I figured they'd topped up my washer liquid as I new that had a leak in.

The next day I took the car out and suddenly the red temperature guage came on and off every few minutes. After arriving home I noticed there wasnt a drop of coolant in the coolant tank and so im guessing this was causing the overheating. It was also making a very loud rattling noise when revving just before I got home.

Do you think the garage have caused a leak? I've checked the oil and its still a dark black, and Im pretty sure it's not mixing with the coolant. I'm taking it back to the garage tomorrow.

Shall I just fill the cooling system with distilled water for the drive there?

Thanks a lot

Alex[/quote]



i def wouldnt drive it without coolant in it!!
mintalkin
until you descover where the leak is from its hard to say wheather the garage cause the problem or its just coincidence. it will cost you a fortune in distilled water to top it up just use normal water untill the leak is fixed and then put the correct antifreeze mix in the system.


Full Colour Version: Few Problems...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.