Help - Search - Members - Calendar
Full Version: Xenon Headlights
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Pogo
Hi, I'm another Newbie to the Forum, so Hi to All.
I have a 2003 Mondeo TDCI with Xenon headlights. The one dip beam bulb has blown, but is it just a simple change of the bulb at home or do I need to take it to a dealer?

Many Thanks[/font]
Steve
[quote name='Pogo' post='1653' date='Jun 9 2008, 09:29 PM']Hi, I'm another Newbie to the Forum, so Hi to All.
I have a 2003 Mondeo TDCI with Xenon headlights. The one dip beam bulb has blown, but is it just a simple change of the bulb at home or do I need to take it to a dealer?

Many Thanks[/font][/quote]

Should be just a bulb
Col_Tubbs
Which side as gone ??

If it's the LH side then the system will be needed to be setup again at about 100 ish a pop plus bulb which Ford will charge about the same again.
Pogo
[quote name='Col_Tubbs' post='1955' date='Jun 29 2008, 10:34 PM']Which side as gone ??

If it's the LH side then the system will be needed to be setup again at about 100 ish a pop plus bulb which Ford will charge about the same again.[/quote]

What do you mean set up?
bn8959
Hi,

Did it turn out to be just a bulb?

My left hand side bulb blew. I have just replaced it with a new bulb (Osram D2S), but it still dosent work. I did various swap tests and it appears to be the metal box behind the headlight (the ballast), which is not working, as if I swap it for the right one, it works.

Col_Tubbs, you refer to a 'reset', Ive noticed there is a far amount of circuitary in the ballast box, does that need resetting, or has that simply blown as well? If so, I guess I will need to replace it.

Time is against me, because my car is booked in for a MOT in a couple of days and I dont really want to pay Ford s to fix it.

Thanks!

Ben
Pogo
[quote name='bn8959' post='6613' date='Oct 23 2008, 05:36 PM']Hi,

Did it turn out to be just a bulb?

My left hand side bulb blew. I have just replaced it with a new bulb (Osram D2S), but it still dosent work. I did various swap tests and it appears to be the metal box behind the headlight (the ballast), which is not working, as if I swap it for the right one, it works.

Col_Tubbs, you refer to a 'reset', Ive noticed there is a far amount of circuitary in the ballast box, does that need resetting, or has that simply blown as well? If so, I guess I will need to replace it.

Time is against me, because my car is booked in for a MOT in a couple of days and I dont really want to pay Ford s to fix it.

Thanks!

Ben[/quote]

Hi Mate,
Yes it was just the bulb in the end, not sure what was meant by 'resetting'


Full Colour Version: Xenon Headlights
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615