Help - Search - Members - Calendar
Full Version: Focus stalling / incorrect idle / broke
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Focus_matt_02
there is a problem with my 1.6zetec focus 02 reg

it trys to stall when slowing down or putting load on the engine e.g. using electrical auxially equipment such as lecy windows or fan it makes the engine pink sometimes

now my mate has told me the wrong battery is on it for a start its a 420amp its at least ment to be a 620 amp and that the alternator will struggle with that

he also said fuel starvation as when it warms up its a absoulute * * * * to move off and will try to stall adn when you put the clutch down and brake its as though it trys to stall the engine he said change the fuel filter and stick some winns injector cleaner you buy it from halfords for like 5

now the warrenty people said it was the alternator and they would need to strip it to find out why on friday well if the wrong battery is on it then surely the alternator is not at fault i have had this car not even a month 2nd hand 62,000 miles but should it have not come with a focus batteyr and not a fiesta like the one in my girlfriends fiesta style 1.25cc handles and drives better than my focus at the minute and puts it to shame

any chance anything like this happend to you lot before the ford TIS the special disk they used to use in 2004 the technical service bulliten in there says its the pcm controller and that needs re programming but thats for 1.8 zetec and 2.0st models i have the 1.6 so dont think it will affect me


Please some one help me i going out my mind with the car its a cracking car best i have had yet i respect it as well so it gets looked after after having 2 renaults and a civic i look after it oh and a sierra 1.8td sapphire glx


Any help would be great


Thanks


Matt

Someone told me today that it could be the ICV (Idle control valve) but i think it could be the fuel filter but yet someone else says alternator as when you turn on anything electrical auxially engine tones down to about 700 rpm
gaving7095
I had very similar issues, thankfully I have a local independant & very reliable garage who diagnosed a faulty PCV (valve) which was 50 to replace & 25 to fit and crankcase ventialtion hose (15 to source & 25 to diagnose & fit). TOUCH WOOD my issues are over now... The car does seem OK.
It seems I was (hopefully :-)) lucky 'cause both of the above parts were relatively cheap to supply & fix. The faulty PCV should have lit the engine warning light straight away but didn't :-(
From all the reading I did it seems that Ford used slightly "dodgy" hoses throughout the Focus engine - hopefully your issue can be easily found & cheaply fixed!


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615