Help - Search - Members - Calendar
Full Version: Engine misfire
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Renegade
Hi everyone.
I've got a 1999 Mondeo 2.0 GLX

I was coming home tonight and it started to loose power, felt like it was misfiring.
I checked the plugs and all is well (No wet plugs) checked the air filter and that is ok.
Any ideas please, it starts no problem and will idle for a while, then the engine starts to stall, I could smell rotten eggs when I revved it (Cat).

Any help would be appreciated.
Thanks in advance.
Phil.
gaz6076
The rotten eggs smell will be your cat. Thing is cats don't just fail. The missfire has probably caused it to fail and replacing your cat won't solve the problem.

The missfire is probably caused by a faulty coil pack or the plug leads but you would usually get a wet plug on the failing cylinder. When the engine is missfiring pull a lead of one at a time. The engine should almost cut out if that cylinder is still firing (because it will only be running on at most 2 cylinders) If the engine doesn't change then you know that's the faulty cylinder.
Renegade
[quote name='gaz6076' post='49666' date='Nov 18 2009, 08:17 PM']The rotten eggs smell will be your cat. Thing is cats don't just fail. The missfire has probably caused it to fail and replacing your cat won't solve the problem.

The missfire is probably caused by a faulty coil pack or the plug leads but you would usually get a wet plug on the failing cylinder. When the engine is missfiring pull a lead of one at a time. The engine should almost cut out if that cylinder is still firing (because it will only be running on at most 2 cylinders) If the engine doesn't change then you know that's the faulty cylinder.[/quote]


My apologies to everyone for not posting that I had fixed the problem.

I found a broken wire going to the coil pack (The far right of the 3 as you look from the front) it had been repaired before (Soldered by previous owner) I resoldered it for now until I get the chance to fit a new block to it.

Problem solved !
Thanks for the reply.


Full Colour Version: Engine misfire
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615