Help - Search - Members - Calendar
Full Version: mondeo mkIII rear washer jet
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
chris bowman
water was bearly running out the rear washer jet so for the sake of about 3 quid i brought a new one. water still just runs out a bit better than before. i presume that there is possibly a leak but if there is it is not obvious ie no excess water or the pump is possibly gone. has anyone else had this and if so is there a common problem?
mintalkin
it is common for the pumps to pack up, also there is a joint in the pipe behind the n/s panel above the rear passenger seat that can sometimes become apart.
chris bowman
[quote name='mintalkin' post='49657' date='Nov 18 2009, 07:50 PM']it is common for the pumps to pack up, also there is a joint in the pipe behind the n/s panel above the rear passenger seat that can sometimes become apart.[/quote]

cheers mate will look there first as i can hear the pump wirring when i operate it.
chris bowman
[quote name='chris bowman' post='49665' date='Nov 18 2009, 08:13 PM']cheers mate will look there first as i can hear the pump wirring when i operate it.[/quote]

did it this morning on the os panel there was a wet patch that smelt of screenwash!!!
took it off and the junction had come undone!
well done mate thanks!
mintalkin
glad to help.
Derekp
I had the same problem but when I looked at the pipe i does leak checked the connection but still no water coming out of nozzle


Full Colour Version: mondeo mkIII rear washer jet
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.