Help - Search - Members - Calendar
Full Version: Revs sticking
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
etch87
Hello i have a 96 1.6 zetec escort, for example if ive been driving for awhile n if i put my clutch in while still moving the revs stick at various points and even when i come to a stop it takes 4 or 5 seconds for the revs to drop to idle, i dont understand it doesn't do this all the time though it seems to me something is sticking, any ideas? be much appreciated if someone could help thanks
vinnyvangough
This will more than likely be your idle control valve (ICV).

This will be gunked up a bit and need cleaning out with carb cleaner or such.

Big thread and how to guide on www.fordescortclub.co.uk
InstructorPiggy
amen to that Vin
etch87
[quote name='InstructorPiggy' post='50623' date='Nov 25 2009, 10:26 AM']amen to that Vin[/quote]
Hi guys thanks for the replys i changed the idle control valve about 2 months ago thinking it was to do with another problem ive got with the cold start but no difference. im currently on holiday and took my car with me and so far it hasnt been sticking it sometimes does and sometimes doesnt!.
As for my cold start ive replaced the control valve throttle valve and air flow sensor and no difference. Also checked vacuum hoses so all i can think of is the air temperature sensor il change that and see if it will sort it. The car is fine when its warmed up.
Has anybody had the same problem?
roger4321
[quote name='etch87' post='51069' date='Nov 28 2009, 02:31 PM']Hi guys thanks for the replys i changed the idle control valve about 2 months ago thinking it was to do with another problem ive got with the cold start but no difference. im currently on holiday and took my car with me and so far it hasnt been sticking it sometimes does and sometimes doesnt!.
As for my cold start ive replaced the control valve throttle valve and air flow sensor and no difference. Also checked vacuum hoses so all i can think of is the air temperature sensor il change that and see if it will sort it. The car is fine when its warmed up.
Has anybody had the same problem?[/quote]
Could be the throttle position sensor its on the throttle body at the butterfly.


Full Colour Version: Revs sticking
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.