Help - Search - Members - Calendar
Full Version: stil bad brakes
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
Domz78
hi i have a 1.3 escort van mk4 petrol my problem is i have changed discs pads rear shoes moted the van and recently the brake pedal just sinks softly to the floor this will stop the van JUST hardly nothing i have removed the resovar cap wen freeing pistons on calipers i thought this prob was master cylinder but i replaced that with brand new 1 there is no leaks and i have bled system ok but same thing could this be servo?????
InstructorPiggy
Either leaky servo or there gota be a leak somewhere!

Are the rear brakes correctly adjusted??

Piggy :)
Domz78
[quote name='InstructorPiggy' post='52883' date='Dec 7 2009, 04:11 PM']Either leaky servo or there gota be a leak somewhere!

Are the rear brakes correctly adjusted??

Piggy :)[/quote]
hi there bud well at mot the mechanic who done it said the rea shoes need adjustin to pass so he done them there so i would say ok but i aint had a look in rear hubs since doing the shoes but this has bin going on a while and all round the back plate is dry pedal seems to go hard wen engine is switched off many cheers for any help dom
InstructorPiggy
sounds like a leaky servo to me :)
colmac1
hi there have you tried the brake cylinder an the back there is one under the back end at the drivers side the brake pipes run in to it and there is a rod that goes on to the back axle i had the same problem let me know how you get on.
Domz78
[quote name='colmac1' post='54140' date='Dec 13 2009, 02:18 PM']hi there have you tried the brake cylinder an the back there is one under the back end at the drivers side the brake pipes run in to it and there is a rod that goes on to the back axle i had the same problem let me know how you get on.[/quote]
hello m8 changed servo and stil same problim ??? pumping brakes to stop!! master cylinder is brand new and no leaks?? nowere any ideas ta dom
colmac1
[quote name='Domz78' post='54934' date='Dec 17 2009, 03:10 PM']hello m8 changed servo and stil same problim ??? pumping brakes to stop!! master cylinder is brand new and no leaks?? nowere any ideas ta dom[/quote]
how u doin pal av got the haynes workshop book for the van i will have a look and let u know
Domz78
[quote name='colmac1' post='54950' date='Dec 17 2009, 05:44 PM']how u doin pal av got the haynes workshop book for the van i will have a look and let u know[/quote]
any chance yu could tel me wat that rear cylinder is called above the axl ??? ta dom
InstructorPiggy
Not a brake cylinder...its a...ah damn it...on tip of my tongue....a brake displacement valve or somthing like that...

it alters how much braking goes to the rear brakes depending on how much in the back of the van....only thing will affect is if the van is very heavily loaded...shouldnt mean there is no brakes...all it does is allow more brake pressure to rear brakes.

Describe it in detail...when you are trying to brake...you pump the brake...is the brake pedal hard??? or soft??? are you pumping an inch or to the floor???

:)
Saltire1964
The valve above the rear axle is a load sensor, if it is seized you may have no fluid going to the rear wheels. This would make it impossible to bleed the brakes properly as the valve is not allowing the air to pass through. Give the whole thing a good soak in releasing fluid then work the lever up & down until it feels free then try bleeding the brakes again.
Domz78
[quote name='InstructorPiggy' post='54990' date='Dec 17 2009, 08:05 PM']Not a brake cylinder...its a...ah damn it...on tip of my tongue....a brake displacement valve or somthing like that...

it alters how much braking goes to the rear brakes depending on how much in the back of the van....only thing will affect is if the van is very heavily loaded...shouldnt mean there is no brakes...all it does is allow more brake pressure to rear brakes.

Describe it in detail...when you are trying to brake...you pump the brake...is the brake pedal hard??? or soft??? are you pumping an inch or to the floor???

:)[/quote]
when i come up to a juntion i pump the brake the 1st pump is strait to the floor 2nd pump more of a pedal 3rd perfect brake then if i hold my foot on there it just goes down slowly back to the floor wen engine is switched off it seems to have a hard pedal 1.3 ovh engine if that helps many thanks 4 help dom
InstructorPiggy
sounds like air in system for sure....LOAD SENSOR....thats the one....as the lad said, free it up.

But it should be checked on MOT, will fail if seized, so be surprised if it was.

Needs bleeding...or go back to the garage that said it was ok!
roger4321
[quote name='Domz78' post='55008' date='Dec 17 2009, 10:23 PM']when i come up to a juntion i pump the brake the 1st pump is strait to the floor 2nd pump more of a pedal 3rd perfect brake then if i hold my foot on there it just goes down slowly back to the floor wen engine is switched off it seems to have a hard pedal 1.3 ovh engine if that helps many thanks 4 help dom[/quote]
That is absolutely a rear brake adjustment or fitment problem air would give you a spongy pedal sinking after pumped sugests leaking master or slave cylinder. Take your rear hubs off and check that the shoes are assembled/adjusted properly, and don't drive it till it's sorted.


Full Colour Version: stil bad brakes
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.