Help - Search - Members - Calendar
Full Version: lacking power
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
craig_y2k2008
i`ve just had a escort mk6 1.6 1995`and its lacking power it seems to have a flat spot in the revs from about 3500 revs to about 5500 any ideas wot could be wrong with it ,thanks craig
InstructorPiggy
millage?

last service?

any modifications?

Does it pick up then after 5500rpm?

does it change depending on weather?

Piggy :)
craig_y2k2008
[quote name='InstructorPiggy' post='57484' date='Jan 2 2010, 12:12 PM']millage?

last service?

any modifications?

Does it pick up then after 5500rpm?

does it change depending on weather?

Piggy :)[/quote]
yeah its better after that its just a flat spot in the revs its holding back quite abit its standard apart from a cone air filter , i,ve just fitted the performace exhaust and cat off my old car and its abit better but still not performing how it should my old escort with the same engine was alot quicker oh and its done 71000 and got service history and dont know if it changes if weather is diff as i`ve only had the car 2 days any idea`s on wot it could be would be a great help
InstructorPiggy
2000rpm of lack of power is a bit more than a flat spot! :lol:

I would suggest (and is what I would do) to return the mods to standard and see if still the same.

:)
craig_y2k2008
[quote name='InstructorPiggy' post='57586' date='Jan 2 2010, 10:35 PM']2000rpm of lack of power is a bit more than a flat spot! :lol:

I would suggest (and is what I would do) to return the mods to standard and see if still the same.

:)[/quote]
it was standard when i had it i,ve put some redex in in and gave it a good thrashing and its loads better now


Full Colour Version: lacking power
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.