• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


genie20

New Member
  • Content count

    1
  • Joined

  • Last visited

About genie20

  • Rank
    Newbie

Profile Information

  • Ford Model
    KA
  1. Hi everyone, I have 4 problems with my KA, It is a V reg 1999 For KA 1.3, I only bought it last October which at the time had 12 months MOT and 6 months tax on the vehicle. It only done 34000 mile at time of purchase and now since October 2007 it has done just over 47000 miles. 1) When driving and i dip my clutch in to change gear my car over revs even thou my foot is not on the accelerator, it is not to bad in low gears but in high gears it gets louder and sometimes when coming to a stop it over revs really loud until i have fully stopped. I sprayed the throttle cable about 1 month ago with WD40 and the reving stopped but for the past week it has came back, i resprayed cable but this time it only stops for about a day or revs are very quiet then comes back. Is this more than likely the throttle cable sticking? 2) Sometimes when for example in first gear turning steering wheel fully left/right and just ready to move car a little the car cuts out for no apparant reason as if you need to accelerate even thou i got clutch rite in, anyone know what may be the cause? 3) Mainly when i got someone in the back but not always need someone in the back of the car for this to happen when i go over any humps/bumps etc i here a knocking noise from the car, anyone know what the problem may be? 4) My rear lights are playing up, usually when using the boot. opening and shutting. when i brake and indicate right the right indicator flashes strangely and the left brake light flashes both together but when i dont brake the lights work fine. I cleaned connectors on car using sand paper and it was ok for few days but it keeps coming back and requires fiddling around with rear lights to sort out again, usually happens when i open boot and shut it even thou i shut it carefuly? same happens when i brake and idicate left I hope all these problems is not going to cost an arm and a leg. I am not a car techie but wanted to know if anyone knew what problems could be before i take it to a car garage so i could tell them some possible reasons on why it might be. Any help appreciated. I got a Haynes Manual for P reg onwards i bought a few weeks ago if that helps. Thank you, Genie20