Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


gregcopp

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About gregcopp

  • Rank
    Newbie

Profile Information

  • Ford Model Fiesta
  1. Hi LS auto, Thanks for the great post. U seem to know exactly what the problem is. I noticed my faults when we had very heavy rain, and the car was fine for a few weeks during the really cold spell last year. I'm convinced water was the cause but has probably done permanent damage. So can I just ask do u think I should first replace the hydrolic control module or just the whole ABS module? Someone also advised me to clean the ABS sensors as this could cause the same symptoms? Ford need to accept this as a design or manufacturing fault. Thnks again...
  2. Alright mate,

    I think i posted a reply on here but dont know if u got it....basically have exactly the same problem u had - ABS and handbrake light, engine warning light and lost speedo...pretty intermittent but recently havent worked for weeks....did u ever get a solution to it? All ppl seem to offer are various possibilities...

    Thanks...

  3. Hi Mate, A about your problem below, i have EXACTLY the same problem with my '05 Fiesta zetec. It has been goin on for a while now, the only time it was ok for weeks was during the recent very cold spell we had which makes me think it could be moisture somewhere.....just wondering if u ever got the problem sorted?? Cheers...