• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


otiab

Budding Enthusiast
  • Content count

    9
  • Joined

  • Last visited

About otiab

  • Rank
    Newbie

Profile Information

  • Ford Model
    ka
  1. KA rev's at 3000rpm???

    got it sorted the prob was the water temp sensor thanks for all the help
  2. KA rev's at 3000rpm???

    got the car back from the garage and its still not fixed the icv is new but now the car is hard to start and the idle is all over the place :(
  3. ka problem

    sounds like the prob im having with mine! are your rev's high??
  4. KA rev's at 3000rpm???

    ICV was changed and it did help but the rev's now at 1500 rpm and the eng light is on, so its in the garage now :( thanks for all the help
  5. KA rev's at 3000rpm???

    i will do it in the morning i did not think about doing that.
  6. KA rev's at 3000rpm???

    me too i just dont know lol all the plugs are ok oil is ok all pipes and other things look ok too :( it dont miss fire and it starts fine, its just the rev's start climing might have to take it to the garage....
  7. KA rev's at 3000rpm???

    thanks ive checked all the breather pipes and there ok. could it be the idle controle valve???
  8. KA rev's at 3000rpm???

    thanks the old pugs was ok but when i serviced the ka this is when the new plugs went sooty as the car did not run right. dose ths idel controle valve control the choke? be for i serviced the ka it was running good and idling ok :(
  9. hi all ive not long brought a 2003 1.3 duratec i look at the oil and was not good so i changed the oil,filter's and plugs. how ever the car runs like a bag of poo when i start the car it will idle for a bit then the revs will slowley climb to about 3000rpm ive looked at all my pipes and cant see anything wrong but i looked at my new plugs and they was sooty. hope some one can help me as i need my car soon for when i start my new job