Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Cst101

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About Cst101

  • Rank
    Newbie

Profile Information

  • Gender*
    Male
  • Ford Model
    2003 Ford Mondeo Graphite TDCI
  1. Hi All, I have a 2003 Fiesta 1.4 TDCI For some reason whilst driving the the spedo needle drops to zero and the milage reading just displays dashes - - - - - - Does anyone have any idear what could cause this? Cst101
  2. Hi All, My radio started losing reception and making a funny distorted noise yet CD is fine. Is there a software update that could sort this or is it knackered? Many Thanks Cst101
  3. Hi All, I have a Mark 6 Fiesta 1.4 TDCI 2003. This may seem like a silly question. Should the cap turn and tighten then turn again or just screw and not turn any more?
  4. Hi All I have 2003 1.4 TDCI Fiesta. Whilst doing about 60mph the car started crawling with 'EAC FAILURE' flashing. Does anyone have any idear what this could be? Any help appriciated!
  5. Hi All, I have a 2003 1.4 TDCI Fiesta. When revs fall below 15000 oil lights fllickers on. Ive had a oil change done and oil level is fine. Any idears please? Thanks Cst101
  6. Hi All, I have a Mark 5 2003 1.4 TDCI Fiesta. The oil light flickers when the clutch is pressed and at low idle. The oil level is fine. Does anyone have any idears? Cst101
  7. Hi all, Does anyone know where the aux fuse box in the engine compartment is located. Many Thanks Cst101
  8. Hi all, I have a problem with my fiesta. It started and lasted for about a minute before stalling and wont start again. Battery is full and all fuses in the glove compartment are fine. ECU/PCM will not communicate with diagnostic software. Im stuck for idears. Any help would be much appriciated! Cst101